Bug 780086 - (SOA-2453) generatePackageFile in business_ruleservice_ruleAgent QS fails
generatePackageFile in business_ruleservice_ruleAgent QS fails
Status: CLOSED DUPLICATE of bug 780177
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0.ER3
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: trev
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-21 03:52 EDT by Lukáš Petrovický
Modified: 2010-11-25 06:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
java version "1.6.0_20" OpenJDK Runtime Environment (IcedTea6 1.9.1) (fedora-44.1.9.1.fc14-x86_64) OpenJDK 64-Bit Server VM (build 19.0-b06, mixed mode)
Last Closed: 2010-11-25 06:30:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2453 None None None Never

  None (edit)
Description Lukáš Petrovický 2010-10-21 03:52:19 EDT
project_key: SOA

When trying to regenerate the Drools package from the Ant buildfile in business_ruleservice_ruleAgent QS, I get the following exception:

[lpetrovi@steam business_ruleservice_ruleAgent]$ ant generatePackageFile
Buildfile: build.xml

...

generatePackageFile:
     [echo] Going to regenerate ruleAgent/org.jboss.soa.esb.services.rules.pkg
     [java] Exception in thread "main" org.drools.RuntimeDroolsException: Unable to load dialect 'org.drools.rule.builder.dialect.java.JavaDialectConfiguration:java:org.drools.rule.builder.dialect.java.JavaDialectConfiguration'
     [java] 	at org.drools.compiler.PackageBuilderConfiguration.addDialect(PackageBuilderConfiguration.java:283)
     [java] 	at org.drools.compiler.PackageBuilderConfiguration.buildDialectConfigurationMap(PackageBuilderConfiguration.java:268)
     [java] 	at org.drools.compiler.PackageBuilderConfiguration.init(PackageBuilderConfiguration.java:181)
     [java] 	at org.drools.compiler.PackageBuilderConfiguration.<init>(PackageBuilderConfiguration.java:159)
     [java] 	at org.drools.compiler.PackageBuilder.<init>(PackageBuilder.java:210)
     [java] 	at org.drools.compiler.PackageBuilder.<init>(PackageBuilder.java:143)
     [java] 	at org.drools.builder.impl.KnowledgeBuilderFactoryServiceImpl.newKnowledgeBuilder(KnowledgeBuilderFactoryServiceImpl.java:34)
     [java] 	at org.drools.builder.KnowledgeBuilderFactory.newKnowledgeBuilder(KnowledgeBuilderFactory.java:47)
     [java] 	at org.jboss.internal.soa.esb.services.rules.util.PackageFileGenerator.createPackageFile(PackageFileGenerator.java:74)
     [java] 	at org.jboss.internal.soa.esb.services.rules.util.PackageFileGenerator.main(PackageFileGenerator.java:66)
     [java] Caused by: java.lang.RuntimeException: The Eclipse JDT Core jar is not in the classpath
     [java] 	at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.setCompiler(JavaDialectConfiguration.java:94)
     [java] 	at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.init(JavaDialectConfiguration.java:55)
     [java] 	at org.drools.compiler.PackageBuilderConfiguration.addDialect(PackageBuilderConfiguration.java:279)
     [java] 	... 9 more

BUILD FAILED
/home/lpetrovi/QA/SOA-5.1.0.ER3/jboss-soa-p-5/jboss-as/samples/quickstarts/business_ruleservice_ruleAgent/build.xml:43: Java returned: 1
Comment 1 Kevin Conner 2010-10-21 04:28:59 EDT
Link: Added: This issue depends JBESB-3516
Comment 2 Anne-Louise Tangring 2010-10-27 15:12:31 EDT
Candidate for SOA 5.1.0
Comment 3 David Ward 2010-11-04 13:33:47 EDT
This appears to be a packaging problem with SOA-P, not a bug in JBoss ESB.  See the listings below; you will notice the difference is that SOA-P is missing core-3.4.2.v_883_R34x.jar:

$ ls jbossesb-server-4.9/server/default/deploy/jbrules.esb/
antlr-runtime-3.1.3.jar
core-3.4.2.v_883_R34x.jar
drools-api-5.1.0.jar
drools-compiler-5.1.0.jar
drools-core-5.1.0.jar
drools-decisiontables-5.1.0.jar
drools-jsr94-5.1.0.jar
drools-templates-5.1.0.jar
janino-2.5.15.jar
jbossesb-jbrules.jar
jbrules-service.xml
jsr94-1.1.jar
jxl-2.4.2.jar
META-INF
XPathLanguage.dsl
xpp3_min-1.1.4c.jar

$ ls 5.1.0.ER3/jboss-soa-p-5/jboss-as/server/default/deploy/jbrules.esb/
antlr-runtime-3.1.3.jar
drools-api-5.1.0.BRMS.jar
drools-compiler-5.1.0.BRMS.jar
drools-core-5.1.0.BRMS.jar
drools-decisiontables-5.1.0.BRMS.jar
drools-jsr94-5.1.0.BRMS.jar
drools-templates-5.1.0.BRMS.jar
janino-2.5.15.jar
jbossesb-jbrules.jar
jbrules-service.xml
jsr94-1.1.jar
jxl-2.6.10.jar
META-INF
XPathLanguage.dsl
xpp3_min-1.1.4c.jar

Aside, I thought that SOA-P 5.1 was going to use Drools 5.1.1, not 5.1.0?  When this changes, please note that ecj-3.5.1.jar should be used instead of core-3.4.2.v_883_R34x.jar.
Comment 4 Kevin Conner 2010-11-04 13:37:23 EDT
Thanks David, I already know about this one.  I am talking to Trev about it tomorrow.
Comment 5 Kevin Conner 2010-11-05 06:03:26 EDT
Assigning to Trevor as we have confirmed it is a SOA build issue.
Comment 6 trev 2010-11-08 06:07:17 EST
Link: Added: This issue is a dependency of SOA-2552
Comment 7 trev 2010-11-08 06:09:16 EST
Link: Removed: This issue is a dependency of SOA-2552 
Comment 8 trev 2010-11-08 06:10:12 EST
Link: Added: This issue depends SOA-2552
Comment 9 Kevin Conner 2010-11-25 06:18:28 EST
Link: Added: This issue is a dependency of SOA-2611
Comment 10 Kevin Conner 2010-11-25 06:28:14 EST
Link: Removed: This issue is a dependency of SOA-2611 
Comment 11 Kevin Conner 2010-11-25 06:29:21 EST
Link: Added: This issue duplicates SOA-2552
Comment 12 Kevin Conner 2010-11-25 06:29:40 EST
Link: Removed: This issue depends SOA-2552 
Comment 13 Kevin Conner 2010-11-25 06:30:19 EST
Closing as a duplicate as it has already been done through SOA-2552

Note You need to log in before you can comment on or make changes to this bug.