Bug 780215 - (SOA-2600) ESB: groovy_gateway quickstart causes server stack trace
ESB: groovy_gateway quickstart causes server stack trace
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Documentation, JBossESB, Examples (Show other bugs)
5.1.0.ER4
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-22 11:12 EST by mvanek
Modified: 2015-09-27 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-12 07:42:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2600 None None None Never

  None (edit)
Description mvanek 2010-11-22 11:12:03 EST
project_key: SOA

When the groovy_gateway quickstart deploys, it tries to run a gui console to feed message to a service, but the server logs:
-----------------------------------------------------------------------------------------------------------------------------------------
16:59:51,420 INFO  [EsbDeployment] Starting ESB Deployment 'Quickstart_groovy_gateway.esb'
16:59:52,282 INFO  [GroovyGateway] Starting Groovy Gateway listener
16:59:53,347 WARN  [AbstractThreadedManagedLifecycle] Unexpected error from doRun()
java.lang.RuntimeException: Failed to create component for 'frame' reason: java.awt.HeadlessException
	at groovy.util.FactoryBuilderSupport.createNode(FactoryBuilderSupport.java:354)
	at groovy.util.FactoryBuilderSupport.doInvokeMethod(FactoryBuilderSupport.java:405)
	at groovy.util.FactoryBuilderSupport.invokeMethod(FactoryBuilderSupport.java:207)
	at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:781)
	at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:757)
	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:167)
	at Script1.run(Script1.groovy:37)
	at org.jboss.soa.esb.listeners.gateway.GroovyGateway.doRun(GroovyGateway.java:143)
	at org.jboss.soa.esb.listeners.lifecycle.AbstractThreadedManagedLifecycle.run(AbstractThreadedManagedLifecycle.java:115)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.awt.HeadlessException
	at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
	at java.awt.Window.<init>(Window.java:432)
	at java.awt.Frame.<init>(Frame.java:403)
	at java.awt.Frame.<init>(Frame.java:368)
	at javax.swing.JFrame.<init>(JFrame.java:158)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
	at org.codehaus.groovy.runtime.MetaClassHelper.doConstructorInvoke(MetaClassHelper.java:528)
	at groovy.lang.MetaClassImpl.doConstructorInvoke(MetaClassImpl.java:2347)
	at groovy.lang.MetaClassImpl.invokeConstructor(MetaClassImpl.java:1244)
	at groovy.lang.MetaClassImpl.invokeConstructor(MetaClassImpl.java:1174)
	at org.codehaus.groovy.runtime.InvokerHelper.invokeConstructorOf(InvokerHelper.java:805)
	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeNewN(ScriptBytecodeAdapter.java:227)
	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeNew0(ScriptBytecodeAdapter.java:234)
	at groovy.swing.factory.FrameFactory.newInstance(FrameFactory.groovy:29)
	at groovy.util.FactoryBuilderSupport.createNode(FactoryBuilderSupport.java:344)
	... 9 more
Comment 1 Kevin Conner 2010-11-22 11:21:29 EST
Looks like SOA-906 again.
Comment 2 Anne-Louise Tangring 2010-11-24 14:58:37 EST
Candidate for SOA 5.1.0
Comment 3 Kevin Conner 2010-11-26 11:00:56 EST
Link: Added: This issue depends JBESB-3537
Comment 4 Kevin Conner 2010-11-26 11:03:10 EST
Updated in the ESB documentation and the quickstart readme
Comment 6 Darrin Mison 2011-01-04 19:14:46 EST
Writer: Added: dlesage
Comment 7 mvanek 2011-01-20 05:55:49 EST
Works in ER7.
Comment 8 Laura Bailey 2011-02-12 07:35:38 EST
This JIRA's status was Closed -> Done. I am reopening to edit the release notes text field, and will reclose momentarily.
Comment 9 Laura Bailey 2011-02-12 07:40:35 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: JBoss SOA Platform ships with headless mode enabled. However, some quickstarts require that this mode be disabled in order to run. Refer to the Configuration section of the SOA Getting Started Guide for instructions on disabling headless mode in order to run these quickstarts.

It is not recommended to run JBoss SOA Platform in a production environment with headless mode disabled.
Comment 10 Laura Bailey 2011-02-12 07:41:19 EST
Writer: Removed: dlesage Added: laubai
Comment 11 Laura Bailey 2011-02-12 07:42:28 EST
Setting to Closed -> Done after editing release notes text field and adding Documentation component.

Note You need to log in before you can comment on or make changes to this bug.