This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 780287 - (SOA-2690) jboss-esb.xml configuration is not validated against the appropriate schema
jboss-esb.xml configuration is not validated against the appropriate schema
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 08:02 EST by Kevin Conner
Modified: 2011-02-08 10:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 10:28:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2690 None Closed jboss-esb.xml configuration is not validated against the appropriate schema 2012-02-22 00:19:13 EST

  None (edit)
Description Kevin Conner 2010-12-16 08:02:48 EST
Affects: Release Notes
project_key: SOA
Comment 1 Kevin Conner 2010-12-16 08:03:59 EST
Link: Added: This issue depends JBESB-3545
Comment 2 Kevin Conner 2010-12-17 04:35:11 EST
Updated in ESB codebase
Comment 3 Darrin Mison 2011-01-04 00:53:24 EST
Affects: Added: [Release Notes]
Comment 5 Darrin Mison 2011-01-04 19:14:38 EST
Writer: Added: dlesage
Comment 6 David Le Sage 2011-02-04 00:09:55 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/JBESB-3545

The jboss-esb.xml file was not being validated against the appropriate schema. This problem was caused by the order of the static initialisers within the ModelParser. It has now been fixed so that it is validated correctly.  Note that the setting can be overridden by using the  jbossesb-properties.xml file's org.jboss.soa.esb.deployment.schema.validation property.

Note You need to log in before you can comment on or make changes to this bug.