Bug 780411 - (SOA-2842) KnowledgeAgent cannot use basic auth when accessing resource URL
KnowledgeAgent cannot use basic auth when accessing resource URL
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0.ER7
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.1.0.ER8
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-24 12:10 EST by Jiri Locker
Modified: 2011-05-18 05:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-17 02:44:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2842 Critical Closed KnowledgeAgent cannot use basic auth when accessing resource URL 2013-01-23 23:28:00 EST

  None (edit)
Description Jiri Locker 2011-01-24 12:10:52 EST
project_key: SOA

Agent [insuranceconfig] Message [KnowledgeAgent exception while trying to deserialize KnowledgeDefinitionsPackage  ]
java.lang.RuntimeException: KnowledgeAgent exception while trying to deserialize KnowledgeDefinitionsPackage  
	at org.drools.agent.impl.KnowledgeAgentImpl.createPackageFromResource(KnowledgeAgentImpl.java:664)
	at org.drools.agent.impl.KnowledgeAgentImpl.addResourcesToKnowledgeBase(KnowledgeAgentImpl.java:889)
	at org.drools.agent.impl.KnowledgeAgentImpl.rebuildResources(KnowledgeAgentImpl.java:704)
	at org.drools.agent.impl.KnowledgeAgentImpl.buildKnowledgeBase(KnowledgeAgentImpl.java:584)
	at org.drools.agent.impl.KnowledgeAgentImpl.applyChangeSet(KnowledgeAgentImpl.java:185)
	at org.jboss.internal.soa.esb.services.rules.DroolsRuleBaseHelper.createRuleAgent(DroolsRuleBaseHelper.java:230)
	at org.jboss.internal.soa.esb.services.rules.DroolsRuleService.getRuleBaseStateForRuleAgent(DroolsRuleService.java:332)
	at org.jboss.internal.soa.esb.services.rules.DroolsRuleService.executeStatelessRulesFromRuleAgent(DroolsRuleService.java:115)
	at org.jboss.internal.soa.esb.services.rules.RuleServiceCallHelper.executeStateless(RuleServiceCallHelper.java:286)
	at org.jboss.internal.soa.esb.services.rules.RuleServiceCallHelper.executeRulesService(RuleServiceCallHelper.java:270)
	at org.jboss.soa.esb.actions.BusinessRulesProcessor.executeRulesService(BusinessRulesProcessor.java:144)
	at org.jboss.soa.esb.actions.BusinessRulesProcessor.process(BusinessRulesProcessor.java:125)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:649)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.processPipeline(ActionProcessingPipeline.java:603)
	at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:433)
	at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:550)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.io.IOException: Server returned HTTP response code: 401 for URL: http://127.0.0.1:8080/jboss-brms/org.drools.guvnor.Guvnor/package/soa/LATEST

The KnowledgeAgent applies a change set prepared by org.jboss.internal.soa.esb.services.rules.DroolsRuleAgentHelper, but the generated change set is corrupted as a result of error in processing the configuration properties.
Comment 1 Jiri Locker 2011-01-24 12:12:26 EST
Link: Added: This issue depends JBESB-3563
Comment 2 Kevin Conner 2011-01-24 16:00:30 EST
Updated in ESB codebase.
Comment 3 Jiri Locker 2011-01-28 05:03:03 EST
Fixed in ER8. (/)
Comment 4 Dana Mison 2011-02-17 02:44:05 EST
Release Notes Docs Status: Added: Not Required
Comment 5 Gary Lamperillo 2011-04-29 12:43:58 EDT
This appears to still be an issue.  It works with a changeset in the esb.xml.  I could not get a format of a properties file that works with the esb.xml
Comment 6 Gary Lamperillo 2011-04-29 12:44:34 EDT
SOA-P 5.1 and BRMS 5.1 that is.
Comment 7 Kevin Conner 2011-05-18 05:59:34 EDT
Checked Gary's example, it was missing the enableBasicAuthentication=true property.

Note You need to log in before you can comment on or make changes to this bug.