Bug 780414 - (SOA-2845) Deploying FTP Provider results in ClassNotFoundException
Deploying FTP Provider results in ClassNotFoundException
Status: CLOSED DUPLICATE of bug 779918
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0.ER6
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Default User
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-25 15:47 EST by Will Dinyes
Modified: 2011-01-26 09:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
JBoss SOA-P 5.1.0.ER6, Windows
Last Closed: 2011-01-26 04:33:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stacktrace.txt (7.72 KB, text/plain)
2011-01-25 15:50 EST, Will Dinyes
no flags Details
ftpfile-cache-config.xml (5.41 KB, text/xml)
2011-01-25 15:51 EST, Will Dinyes
no flags Details
jboss-esb.xml (1.62 KB, text/xml)
2011-01-25 15:52 EST, Will Dinyes
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2845 None None None Never

  None (edit)
Description Will Dinyes 2011-01-25 15:47:48 EST
Affects: Interactive Demo/Tutorial
Complexity: Medium
project_key: SOA

When attempting to run the FTP action quickstart (or deploy an FTP Provider), there appears to be an issue with locating the org.jboss.cache.TreeCacheListener class.

This is caused, I think,  by the remoteFileSystemStrategy-cacheListener setting of org.jboss.soa.esb.listeners.gateway.remotestrategies.cache.DeleteOnEvictTreeCacheListener, also possibly by the remoteFileSystemStrategy-configFile setting.  I'm using ones common in the quickstart, but have developed a simple example which will be used in JBoss courseware (example files attached).

I've tried copying over the jbosscache-core.jar and jbosscache-pojo.jar files from the "all" instance, but I'm not getting any better results.  I suspect this is due to using JBoss Cache 3.0.1 (which I believe is the supported cache for EAP 5).
Comment 1 Will Dinyes 2011-01-25 15:50:59 EST
Stacktrace of execption
Comment 2 Will Dinyes 2011-01-25 15:50:59 EST
Attachment: Added: stacktrace.txt
Comment 3 Will Dinyes 2011-01-25 15:51:44 EST
Cache config file (from quickstart helloworld-ftp-action)
Comment 4 Will Dinyes 2011-01-25 15:51:44 EST
Attachment: Added: ftpfile-cache-config.xml
Comment 5 Will Dinyes 2011-01-25 15:52:09 EST
JBoss ESB descriptor which fails on deployment.
Comment 6 Will Dinyes 2011-01-25 15:52:09 EST
Attachment: Added: jboss-esb.xml
Comment 7 Kevin Conner 2011-01-26 04:33:33 EST
Link: Added: This issue duplicates SOA-2278
Comment 8 Will Dinyes 2011-01-26 09:05:40 EST
Ah.  Understood.  Duplicated.  I'll watch the other issue.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.