Bug 780520 - (SOA-2953) Restarting SOA-P server with deployed BPEL process raises 2011-03-02 14:47:27,079 ERROR [org.apache.juddi.v3.client.config.UDDIClerk] (Thread-21) Unable to register service HelloService .null java.lang.reflect.UndeclaredThrowableException
Restarting SOA-P server with deployed BPEL process raises 2011-03-02 14:47:27...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB, riftsaw (Show other bugs)
5.2.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.2.0 GA
Assigned To: Kurt Stam
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-02 15:02 EST by Len DiMaggio
Modified: 2011-11-07 20:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
SIA 5.1 GA
Last Closed: 2011-11-07 20:26:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (597.47 KB, text/x-log)
2011-03-02 15:03 EST, Len DiMaggio
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2953 None None None Never

  None (edit)
Description Len DiMaggio 2011-03-02 15:02:39 EST
Steps to Reproduce: To recreate the problem:

1) Deploy quickstart bpel_hello_world to a running server, then
2) Restart the server


Workaround Description: Delete the /data/h2, data/hypersonic directories and restart the server
project_key: SOA

To recreate the problem:

1) Deploy quickstart bpel_hello_world to a running server, then
2) Restart the server

The exception raised is:

2011-03-02 14:47:27,079 ERROR [org.apache.juddi.v3.client.config.UDDIClerk] (Thread-21) Unable to register service HelloService .null
java.lang.reflect.UndeclaredThrowableException
	at $Proxy422.saveService(Unknown Source)
	at org.apache.juddi.v3.client.config.UDDIClerk.register(UDDIClerk.java:152)
	at org.jboss.soa.bpel.uddi.UDDIRegistrationImpl.registerEPR(UDDIRegistrationImpl.java:163)
	at org.jboss.soa.bpel.runtime.ws.EndpointManager.createEndpoint(EndpointManager.java:200)
	at org.jboss.soa.bpel.runtime.engine.ode.JAXWSBindingContext.activateMyRoleEndpoint(JAXWSBindingContext.java:92)
	at org.apache.ode.bpel.engine.BpelProcess.activate(BpelProcess.java:619)
	at org.apache.ode.bpel.engine.BpelEngineImpl.registerProcess(BpelEngineImpl.java:354)
	at org.apache.ode.bpel.engine.BpelServerImpl.register(BpelServerImpl.java:321)
	at org.jboss.soa.bpel.runtime.engine.ode.BPELEngineImpl.handleEvent(BPELEngineImpl.java:586)
	at org.jboss.soa.bpel.runtime.engine.ode.BPELEngineImpl.access$100(BPELEngineImpl.java:58)
	at org.jboss.soa.bpel.runtime.engine.ode.BPELEngineImpl$ProcessStoreListenerImpl.onProcessStoreEvent(BPELEngineImpl.java:641)
	at org.apache.ode.store.ProcessStoreImpl.fireEvent(ProcessStoreImpl.java:618)
	at org.apache.ode.store.RiftSawProcessStore$DeployScheduler.fireStateChange(RiftSawProcessStore.java:202)
	at org.apache.ode.store.RiftSawProcessStore$DeployScheduler.doDeploy(RiftSawProcessStore.java:184)
	at org.apache.ode.store.RiftSawProcessStore$DeployScheduler.run(RiftSawProcessStore.java:103)
Caused by: java.util.concurrent.ExecutionException: java.lang.reflect.InvocationTargetException
	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:252)
	at java.util.concurrent.FutureTask.get(FutureTask.java:111)
	at org.jboss.internal.soa.esb.registry.server.JuddiInVMServerTransport$TaskHandler.invoke(JuddiInVMServerTransport.java:463)
	... 15 more
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.jboss.internal.soa.esb.registry.server.JuddiInVMServerTransport$TaskHandler$1.call(JuddiInVMServerTransport.java:459)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: javax.persistence.PersistenceException: org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [org.apache.juddi.model.BindingTemplate#uddi:riftsaw.jboss.org:bindings-helloservice-helloport]
	at org.hibernate.ejb.AbstractEntityManagerImpl.throwPersistenceException(AbstractEntityManagerImpl.java:614)
	at org.hibernate.ejb.AbstractEntityManagerImpl.persist(AbstractEntityManagerImpl.java:226)
	at org.apache.juddi.api.impl.UDDIPublicationImpl.saveService(UDDIPublicationImpl.java:534)
	... 10 more
Caused by: org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [org.apache.juddi.model.BindingTemplate#uddi:riftsaw.jboss.org:bindings-helloservice-helloport]
	at org.hibernate.event.def.AbstractSaveEventListener.performSave(AbstractSaveEventListener.java:191)
	at org.hibernate.event.def.AbstractSaveEventListener.saveWithGeneratedId(AbstractSaveEventListener.java:144)
	at org.hibernate.ejb.event.EJB3PersistEventListener.saveWithGeneratedId(EJB3PersistEventListener.java:49)
	at org.hibernate.event.def.DefaultPersistEventListener.entityIsTransient(DefaultPersistEventListener.java:154)
	at org.hibernate.event.def.DefaultPersistEventListener.onPersist(DefaultPersistEventListener.java:110)
	at org.hibernate.impl.SessionImpl.firePersist(SessionImpl.java:638)
	at org.hibernate.impl.SessionImpl.persist(SessionImpl.java:630)
	at org.hibernate.engine.EJB3CascadingAction$1.cascade(EJB3CascadingAction.java:28)
	at org.hibernate.engine.Cascade.cascadeToOne(Cascade.java:302)
	at org.hibernate.engine.Cascade.cascadeAssociation(Cascade.java:246)
	at org.hibernate.engine.Cascade.cascadeProperty(Cascade.java:195)
	at org.hibernate.engine.Cascade.cascadeCollectionElements(Cascade.java:332)
	at org.hibernate.engine.Cascade.cascadeCollection(Cascade.java:273)
	at org.hibernate.engine.Cascade.cascadeAssociation(Cascade.java:249)
	at org.hibernate.engine.Cascade.cascadeProperty(Cascade.java:195)
	at org.hibernate.engine.Cascade.cascade(Cascade.java:154)
	at org.hibernate.event.def.AbstractSaveEventListener.cascadeAfterSave(AbstractSaveEventListener.java:479)
	at org.hibernate.event.def.AbstractSaveEventListener.performSaveOrReplicate(AbstractSaveEventListener.java:357)
	at org.hibernate.event.def.AbstractSaveEventListener.performSave(AbstractSaveEventListener.java:204)
	at org.hibernate.event.def.AbstractSaveEventListener.saveWithGeneratedId(AbstractSaveEventListener.java:144)
	at org.hibernate.ejb.event.EJB3PersistEventListener.saveWithGeneratedId(EJB3PersistEventListener.java:49)
	at org.hibernate.event.def.DefaultPersistEventListener.entityIsTransient(DefaultPersistEventListener.java:154)
	at org.hibernate.event.def.DefaultPersistEventListener.onPersist(DefaultPersistEventListener.java:110)
	at org.hibernate.event.def.DefaultPersistEventListener.onPersist(DefaultPersistEventListener.java:61)
	at org.hibernate.impl.SessionImpl.firePersist(SessionImpl.java:647)
	at org.hibernate.impl.SessionImpl.persist(SessionImpl.java:621)
	at org.hibernate.impl.SessionImpl.persist(SessionImpl.java:625)
	at org.hibernate.ejb.AbstractEntityManagerImpl.persist(AbstractEntityManagerImpl.java:220)
	... 11 more
Comment 1 Len DiMaggio 2011-03-02 15:03:07 EST
Attachment: Added: server.log
Comment 2 Gary Brown 2011-04-04 15:19:45 EDT
Any ideas Kurt?
Comment 3 Gary Brown 2011-04-11 10:06:52 EDT
Hi Kurt - back to you, but let me know if there is any riftsaw aspects I need to deal with.
Comment 4 Kurt Stam 2011-06-10 13:47:51 EDT
Issue no longer happens on jUDDI-3.1.0.
Comment 5 Len DiMaggio 2011-08-29 17:19:49 EDT
Verified fixed in ER3 build.
Comment 6 David Le Sage 2011-11-07 20:25:39 EST
Temporarily reopening to update release note info.
Comment 7 David Le Sage 2011-11-07 20:25:54 EST
Release Notes Docs Status: Added: Not Required
Writer: Added: dlesage

Note You need to log in before you can comment on or make changes to this bug.