Bug 780774 - (SOA-3227) Wise SOAPClient SOAPFaultException lost
Wise SOAPClient SOAPFaultException lost
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.1.0 GA
Unspecified Unspecified
high Severity high
: ---
: One Off Releases
Assigned To: Rick Wagner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 15:42 EDT by david.boeren
Modified: 2012-08-30 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-30 14:41:53 EST
Type: Support Patch
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
SOA-3227-patch.zip (176.20 KB, application/zip)
2011-08-10 06:08 EDT, Julian Coleman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3654 Major Open Wise SOAPClient SOAPFaultException lost 2012-09-10 11:49:38 EDT
JBoss Issue Tracker SOA-3227 Major Closed Wise SOAPClient SOAPFaultException lost 2012-09-10 11:49:37 EDT

  None (edit)
Description david.boeren 2011-07-28 15:42:44 EDT
Patch Instructions: PATCH NAME: SOA-3227
PRODUCT NAME:JBoss Enterprise SOA Platform
VERSION: 5.1.0.GA
SHORT DESCRIPTION: This patch will cover an issue described on https://issues.jboss.org/browse/JBESB-3654
LONG DESCRIPTION:
 Wise will allow expected exceptions to be returned as an InvocationResult but will trap anything it does not recognise and throw it back to the invoker as an exception. This terminates the pipeline and the remainder of the pipeline is prevented from processing the valid SOAP response because wise is turning it into an exception, thereby treating it in a different manner from the exceptions that are defined within the WSDL (and expected). It is still visible through the exception processing but shouldn't be, it should be treated in the same manner as other SOAP faults.
MANUAL INSTALL INSTRUCTIONS:
  Following, the required actions to apply this patch:
  1 - Locate "soap.esb" folder ($JBOSS_HOME/server/$CONFIGURATION/deploy/soap.esb);
  2 - Remove the "jbossesb-soap.jar", "jboss-wise-1.0.aop", and "wise-core.jar" files;
  3 - Put the new versions of "jbossesb-soap.jar", "jboss-wise-1.0.aop", and "wise-core.jar" into this folder;
COMPATIBILITY:
DEPENDENCIES: NONE
SUPERSEDES: NONE
SUPERSEDED BY: NONE
CREATOR: Julian Coleman
DATE: 10-Aug-2011
Patch Repository Link: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=7963
Support Case Reference: https://c.na7.visual.force.com/apex/Case_View?id=500A0000007BBvM&sfdc.override=1
project_key: SOA

Wise will allow expected exceptions to be returned as an InvocationResult but will trap anything it does not recognise and throw it back to the invoker as an exception. This terminates the pipeline and the remainder of the pipeline is prevented from processing the valid SOAP response because wise is turning it into an exception, thereby treating it in a different manner from the exceptions that are defined within the WSDL (and expected). It is still visible through the exception processing but shouldn't be, it should be treated in the same manner as other SOAP faults.
Comment 1 david.boeren 2011-07-28 15:43:22 EDT
This is a one-off patch request for SOA-3205 to be made against SOA-P 5.1.0
Comment 2 david.boeren 2011-07-28 15:43:22 EDT
Link: Added: This issue is related to SOA-3205
Comment 3 tcunning 2011-08-02 16:48:03 EDT
Link: Added: This issue relates to JBESB-3654
Comment 4 tcunning 2011-08-02 16:49:21 EDT
ESB tag for this fix :
http://svn.jboss.org/repos/labs/labs/jbossesb/tags/GSS-SOA-3227/

tcunning@localhost:soap]$ svn commit
Adding         soap/aop/java/org/jboss/internal/soa/esb/soap/wise/WSMethodInvokeAspect.java
Sending        soap/aop/resources/META-INF/jboss-aop.xml
Sending        soap/src/main/java/org/jboss/soa/esb/actions/soap/wise/SOAPClient.java
Transmitting file data ...
Committed revision 37335.

Please note that this is turned off by default, but enableable through a SOAPClient property :

<property name="ContinueOnSOAPFault" value="true"/>
Comment 5 Julian Coleman 2011-08-08 17:01:12 EDT
Patch zip with signed jar.
Comment 6 Julian Coleman 2011-08-08 17:01:12 EDT
Attachment: Added: SOA-3227-patch.zip
Comment 8 Julian Coleman 2011-08-10 06:07:42 EDT
Attachment: Removed: SOA-3227-patch.zip 
Comment 9 Julian Coleman 2011-08-10 06:08:10 EDT
Attachment: Added: SOA-3227-patch.zip
Comment 10 Julian Coleman 2011-08-10 06:09:54 EDT
Patch Instructions: Added: PATCH NAME: SOA-3227
PRODUCT NAME:JBoss Enterprise SOA Platform
VERSION: 5.1.0.GA
SHORT DESCRIPTION: This patch will cover an issue described on https://issues.jboss.org/browse/JBESB-3654
LONG DESCRIPTION:
 Wise will allow expected exceptions to be returned as an InvocationResult but will trap anything it does not recognise and throw it back to the invoker as an exception. This terminates the pipeline and the remainder of the pipeline is prevented from processing the valid SOAP response because wise is turning it into an exception, thereby treating it in a different manner from the exceptions that are defined within the WSDL (and expected). It is still visible through the exception processing but shouldn't be, it should be treated in the same manner as other SOAP faults.
MANUAL INSTALL INSTRUCTIONS:
  Following, the required actions to apply this patch:
  1 - Locate "soap.esb" folder ($JBOSS_HOME/server/$CONFIGURATION/deploy/soap.esb);
  2 - Remove the "jbossesb-soap.jar", "jboss-wise-1.0.aop", and "wise-core.jar" files;
  3 - Put the new versions of "jbossesb-soap.jar", "jboss-wise-1.0.aop", and "wise-core.jar" into this folder;
COMPATIBILITY:
DEPENDENCIES: NONE
SUPERSEDES: NONE
SUPERSEDED BY: NONE
CREATOR: Julian Coleman
DATE: 10-Aug-2011
Comment 12 Filip Elias 2011-08-11 06:03:19 EDT
Patch approved

6f795f340a95f3e6d788433411ef0f6e  SOA-3227-patch.zip
Comment 13 Tushar Gandotra 2011-08-11 07:59:12 EDT
This patch is applicable to JBoss SOA-P 5.1.0. It is available for download
from the following location:
https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=7963
Comment 14 Tushar Gandotra 2011-08-11 07:59:12 EDT
Patch Repository Link: Added: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=7963
Comment 15 Rick Wagner 2011-11-30 14:41:53 EST
Resolved.

Note You need to log in before you can comment on or make changes to this bug.