Bug 780872 - (SOA-3328) Multiple HttpRouter actions collide on endpointUrl
Multiple HttpRouter actions collide on endpointUrl
Status: CLOSED NOTABUG
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.2.0 GA
Assigned To: david.boeren
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 11:02 EDT by david.boeren
Modified: 2011-11-07 19:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-07 19:51:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jboss-esb.xml (1.49 KB, text/xml)
2011-08-30 11:03 EDT, david.boeren
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-3328 None None None Never

  None (edit)
Description david.boeren 2011-08-30 11:02:38 EDT
Help Desk Ticket Reference: https://c.na7.visual.force.com/apex/Case_View?id=500A0000007rtNk&sfdc.override=1
project_key: SOA

We are using ESB to proxy a webservice.  HttpRouter is used to forward the request to the actual service.

It works well when there is only one service, when there is multiple services, the endpointUrl will be override by last ESB service.
for example, if you config the esb services like below 
ESB service01 route to actual service01
ESB service02 route to actual service02
ESB service0n route to actual service0n
ESB service01/02/03 will all route requests to the endpointUrl of service0n.
Comment 1 david.boeren 2011-08-30 11:03:56 EDT
Example esb config for this issue
Comment 2 david.boeren 2011-08-30 11:03:56 EDT
Attachment: Added: jboss-esb.xml
Comment 3 Tom Fennelly 2011-08-31 10:09:07 EDT
Thanks David.  My guess is that this is something to do with how we manage the HttpClient ConnectionManager. 
Comment 5 david.boeren 2011-09-01 09:26:15 EDT
Release Notes Text: Added: Not a bug, the problem was that the http-gateway declarations must have different names.
Comment 6 David Le Sage 2011-11-07 19:51:20 EST
Temporarily reopening for release note status.
Comment 7 David Le Sage 2011-11-07 19:51:35 EST
Release Notes Docs Status: Added: Not Required
Writer: Added: dlesage

Note You need to log in before you can comment on or make changes to this bug.