Bug 781420 - Accept button does not work in some dialogs
Accept button does not work in some dialogs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 06:50 EST by Juan Antonio Martinez
Modified: 2012-01-20 11:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-20 08:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of stdin with -debug option from cmdline (3.88 KB, text/x-log)
2012-01-13 06:50 EST, Juan Antonio Martinez
no flags Details

  None (edit)
Description Juan Antonio Martinez 2012-01-13 06:50:12 EST
Created attachment 555053 [details]
output of stdin with -debug option from cmdline

Description of problem:

I suffer the old eclipse GDK_NATIVE_WINDOWS bug in my new F16 installed from scratch :-(

But with gnome 3 setting this variable by mean of "export" or by mean of editing eclipse.ini has no effect

Version-Release number of selected component (if applicable):

F16 fresh install
Eclipse from Fedora repositories
Version: 3.7.1
Build id: R3_7_1

How reproducible:
Allways

Steps to Reproduce:
1. Start eclipse
2. Create a new project
3. Try to create a new java class
  
Actual results:
Accept button is ignored ( either by keyboard or mouse selecction )

Expected results:
Dialog closes, new class created and opened in editor

Additional info:

Same problem as old GDK_NATIVE_WINDOWS=true, but due to gnome3 (swt problem??) the old solution does not work

Erasing workspace and ${HOME}/.eclipse does not solve the problem
Starting in -debug mode shows no extra info (log attached)
Comment 1 Juan Antonio Martinez 2012-01-20 08:01:55 EST
UPDATE:
Recent updates of eclipse-emf-*, and eclipse-cdt solves the problem.

Thanks
Juan Antonio
Comment 2 Andrew Overholt 2012-01-20 11:28:10 EST
Thanks for letting us know, Juan Antonio.  I've been thinking about this bug all week and while I can't reproduce, I'm very surprised that EMF or CDT fixes it.  If it returns, please let us know and we'll work with upstream on it.

Note You need to log in before you can comment on or make changes to this bug.