Bug 781727 - [abrt] ibus-1.4.0-17.fc16: PyObject_Call: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] ibus-1.4.0-17.fc16: PyObject_Call: Process /usr/bin/python was killed ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:4a61182f23dfbc85fae817f8fcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-14 12:06 EST by Flos Lonicerae
Modified: 2012-01-22 21:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-22 21:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (10.43 KB, text/plain)
2012-01-14 12:06 EST, Flos Lonicerae
no flags Details
File: build_ids (4.28 KB, text/plain)
2012-01-14 12:06 EST, Flos Lonicerae
no flags Details
File: maps (27.64 KB, text/plain)
2012-01-14 12:06 EST, Flos Lonicerae
no flags Details
File: backtrace (93.34 KB, text/plain)
2012-01-14 12:06 EST, Flos Lonicerae
no flags Details

  None (edit)
Description Flos Lonicerae 2012-01-14 12:06:45 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
crash_function: PyObject_Call
executable:     /usr/bin/python
kernel:         3.1.8-2.fc16.i686
pid:            1679
pwd:            /tmp
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           2012年01月15日 星期日 00时53分20秒
uid:            1000
username:       shine

backtrace:      Text file, 95579 bytes
build_ids:      Text file, 4387 bytes
dso_list:       Text file, 10682 bytes
maps:           Text file, 28300 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-o58NfHgUXG,guid=6a44728eb9b7dd2c4f8ce1050000001f
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=432c01ff6dd513b007b81d590000000a-1326558080.424773-578065079
:IBUS_DATAROOTDIR=/usr/share
:GNOME_KEYRING_CONTROL=/tmp/keyring-9dvjyg
:USER=shine
:USERNAME=shine
:PATH=/usr/local/bin:/usr/bin:/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/tmp
:XMODIFIERS=@im=ibus
:LANG=zh_CN.utf8
:GNOME_KEYRING_PID=1093
:GDM_LANG=zh_CN.utf8
:IBUS_PREFIX=/usr
:GDMSESSION=gnome
:DBUS_STARTER_BUS_TYPE=session
:HOME=/home/shine
:SHLVL=1
:XDG_SEAT=seat0
:IBUS_LOCALEDIR=/usr/share/locale
:LOGNAME=shine
:LC_CTYPE=zh_CN.UTF-8
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-o58NfHgUXG,guid=6a44728eb9b7dd2c4f8ce1050000001f
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/shine
:GTK_IM_MODULE=ibus
:XAUTHORITY=/var/run/gdm/auth-for-shine-aCSKfd/database

event_log:
:2012-01-15-01:04:04> Analyzing coredump 'coredump'
:2012-01-15-01:04:08  Coredump references 107 debuginfo files, 31 of them are not installed
:2012-01-15-01:04:09  Setting up yum repositories
:2012-01-15-01:04:09  正在软件仓库中查找所需软件包
:2012-01-15-01:04:29  Packages to download: 6
:2012-01-15-01:04:42  Downloading 8.35Mb, installed size: 8.35Mb. Continue? YES
:2012-01-15-01:04:44  Downloading (1 of 6) pygtk2-debuginfo-2.24.0-3.fc15.i686.rpm: 100
:2012-01-15-01:04:44  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/pygtk2-debuginfo-2.24.0-3.fc15.i686.rpm
:2012-01-15-01:04:45  Caching files from unpacked.cpio made from pygtk2-debuginfo-2.24.0-3.fc15.i686.rpm
:2012-01-15-01:04:46  Downloading (2 of 6) pygobject2-debuginfo-2.28.6-2.fc16.i686.rpm: 100
:2012-01-15-01:04:46  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/pygobject2-debuginfo-2.28.6-2.fc16.i686.rpm
:2012-01-15-01:04:46  Caching files from unpacked.cpio made from pygobject2-debuginfo-2.28.6-2.fc16.i686.rpm
:2012-01-15-01:04:47  Downloading (3 of 6) dbus-python-debuginfo-0.83.0-8.fc15.i686.rpm: 100
:2012-01-15-01:04:47  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/dbus-python-debuginfo-0.83.0-8.fc15.i686.rpm
:2012-01-15-01:04:47  Caching files from unpacked.cpio made from dbus-python-debuginfo-0.83.0-8.fc15.i686.rpm
:2012-01-15-01:04:48  Downloading (4 of 6) pycairo-debuginfo-1.8.8-2.fc14.i686.rpm: 100
:2012-01-15-01:04:48  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/pycairo-debuginfo-1.8.8-2.fc14.i686.rpm
:2012-01-15-01:04:48  Caching files from unpacked.cpio made from pycairo-debuginfo-1.8.8-2.fc14.i686.rpm
:2012-01-15-01:04:53  Downloading (5 of 6) python-debuginfo-2.7.2-5.2.fc16.i686.rpm:  44
:2012-01-15-01:04:58  Downloading (5 of 6) python-debuginfo-2.7.2-5.2.fc16.i686.rpm:  91
:2012-01-15-01:04:59  Downloading (5 of 6) python-debuginfo-2.7.2-5.2.fc16.i686.rpm: 100
:2012-01-15-01:04:59  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/python-debuginfo-2.7.2-5.2.fc16.i686.rpm
:2012-01-15-01:05:04  Caching files from unpacked.cpio made from python-debuginfo-2.7.2-5.2.fc16.i686.rpm
:2012-01-15-01:05:05  Downloading (6 of 6) notify-python-debuginfo-0.1.1-18.fc15.i686.rpm: 100
:2012-01-15-01:05:05  Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835/notify-python-debuginfo-0.1.1-18.fc15.i686.rpm
:2012-01-15-01:05:05  Caching files from unpacked.cpio made from notify-python-debuginfo-0.1.1-18.fc15.i686.rpm
:2012-01-15-01:05:05  Removing /tmp/abrt-tmp-debuginfo-2012-01-15-01:04:05.1835
:2012-01-15-01:05:05  All 107 debuginfo files are available
:2012-01-15-01:05:05  Generating backtrace
:2012-01-15-01:05:26  Backtrace is generated and saved, 95584 bytes

var_log_messages:
:Jan 12 19:54:53 localhost yum[1144]: Erased: policycoreutils-python-2.1.4-13.fc16.i686
:Jan 12 20:04:43 localhost yum[3968]: Installed: python-meh-0.11-2.fc15.noarch
:Jan 12 20:07:13 localhost yum[3984]: Installed: policycoreutils-python-2.1.4-13.fc16.i686
:Jan 15 00:53:20 localhost kernel: [ 1950.701249] python[1679]: segfault at cd540 ip 45f87176 sp bfe0d700 error 4 in libpython2.7.so.1.0[45f5b000+15e000]
:Jan 15 00:53:20 localhost kernel: [ 1950.701318] type=1701 audit(1326560000.056:108): auid=1000 uid=1000 gid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=1679 comm="python" sig=11
:Jan 15 00:53:20 localhost abrt[3639]: Saved core dump of pid 1679 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-01-15-00:53:20-1679 (11862016 bytes)
Comment 1 Flos Lonicerae 2012-01-14 12:06:48 EST
Created attachment 555264 [details]
File: dso_list
Comment 2 Flos Lonicerae 2012-01-14 12:06:50 EST
Created attachment 555265 [details]
File: build_ids
Comment 3 Flos Lonicerae 2012-01-14 12:06:53 EST
Created attachment 555266 [details]
File: maps
Comment 4 Flos Lonicerae 2012-01-14 12:06:56 EST
Created attachment 555267 [details]
File: backtrace
Comment 5 fujiwara 2012-01-15 20:28:13 EST
Do you still reproduce your problem?
I cannot reproduce your problem.
It seems you got an error when ibus_get_engine is called.
Comment 6 Flos Lonicerae 2012-01-16 07:43:55 EST
no, it just happen once, since i update my system.
Comment 7 fujiwara 2012-01-22 21:02:52 EST
OK, I see.

Note You need to log in before you can comment on or make changes to this bug.