This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 78218 - Russian unicode keymap is missing
Russian unicode keymap is missing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
http://www-106.ibm.com/developerworks...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-20 03:36 EST by Yury Konovalov
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.08-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 11:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yury Konovalov 2002-11-20 03:36:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.2b) Gecko/20021022

Description of problem:
There's no any Russian unicode keymap, that make it impossible to type russian
in UTF-8 console mode

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set LANG to ru_RU.UTF-8 in /etc/sysconfig/i18n
2.set KEYTABLE to any file basename from available russian keymaps
/lib/kbd/keytables/i386/qwerty/ru*
3. service keytable restart
4. try to type in russian
	

Actual Results:  latin1 or some other characters appear instead of russian chars.

Expected Results:  there should be at least one working unicode keymap for
russian keyboard. It would be good to have several unicode keymaps for
russian with different layout switching key-sequence
(ctrl-shift,shift-shift,rcontrol, etc.).   


Additional info:

Russian unicode keymap could be found in console-tools package from ALTLinux
Sisyphus package repository
ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/Sisyphus
Comment 1 Eido Inoue 2003-01-05 22:12:38 EST
the ru.map should work with Unicode.

did you do a unicode_start command before loading the ru.map?
Comment 2 Yury Konovalov 2003-01-08 10:37:14 EST
Even if I use unicode_start command it never works for me. I steel think it due to bad keymap file. Manual for unicode_start has this: ... For the keyboard this means that one can attach 16-bit U+xxxx values to keyboard  keys  using loadkeys(1), and have these appear as UTF-8 input to user programs. ... At the same time ru.kmap does not attach 16-bit values to keys:    ...    keycode 21 =    +y      +Y              +206    +238    ... So it seems, that it simply send koi8-r keycodes instead of UNICODE.  As far as I understand, correct UNICODE keymap record for russian should be like this:    ... altgr                   keycode 21 = U+043D        # CYRILLIC SMALL LETTER EN    ... as it is in ruwin-Corwin_ct_sh-UNICODE.map.gz (see above link for console-tools package)  
Comment 3 Eido Inoue 2003-01-08 15:06:17 EST
Can you tell me if you're unable to use Russian using the instructions provided
in the article in developerWorks (URL attached)? I'm capable of doing Russian
this way.
Comment 4 Yury Konovalov 2003-04-16 07:59:44 EDT
still present in RH 9
I quess that unicode keymaps should be included into distro, that use UTF-8
console mode by default, otherwise keyboard layout switching is broken in console.
 
Comment 5 Eido Inoue 2003-07-14 12:48:37 EDT
non-ASCII input into the console won't be supported on UTF-8 based systems (RHL
8+) until the kernel supports it. See the release notes in the next beta for
more info. Of course, input through X will always be supported.
Comment 6 Yury Konovalov 2003-08-10 08:06:36 EDT
No doubt, linux console is not ready for input/output of the whole range of 
UCS-4 due to the different limitations in pc video hardware and maybe linux 
kernel input methods. BUT all this limitations does not affect displaying and 
input of Russian characters. 
Here it is why: 
1) Since release of RH8, the default console font is: LatArCyrHeb 
which has all needed russian glyphs. 
2) If locale set to xx_XX.UTF-8, then console is switching to unicode 
input/output mode (by initscripts). And that's why russian is displaying 
correctly "out of box" (though not in all console application, but this 
issue is not specific to russian). 
3) Since console is in unicode input mode (kbdmode -u, executed by 
initscripts), it expects any keymap loaded use unicode code points instead 
8-bit. RH8-RH9 installers load (and suggest by default) only 8-bit russian 
keymaps, which will never work unless user will hack up configs and install 
support for specific 8-bit locale. 
 
I have read release notes for the new beta, download and give it a try. 
I believe, that fact of unsupporting non-ascii input is not concern to russian 
because it already supported. The only thing that prevent out-of-box support 
is this bug issue. 
 
PS: Let's face it -- why RH installer still suggests deliberately non-working 
option for Russian users, while there is quite working and easy to implement 
solution exists? 
 
Comment 7 Eido Inoue 2003-08-11 10:54:22 EDT
Have you tried the latest package in Rawhide? It includes the new russian map.
Comment 8 Yury Konovalov 2003-08-12 06:05:21 EDT
I was unable to find any new russian keymaps in kbd-1.08-9 from current 
Rawhide, though spec claims that it was replaced at Jul 30. 
Maybe I've missed something. Which file provides the new keymap? 
 
Comment 9 Eido Inoue 2003-08-12 11:26:46 EDT
You're right-- the patch was generated but never applied. The patch is applied
in release 10. It replaces the old ru.map.

Note You need to log in before you can comment on or make changes to this bug.