Bug 78219 - Installer freezes on Twinhead
Installer freezes on Twinhead
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-11-20 03:45 EST by udippel
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
This is the lspci -v output. You might get some info from it ...? (3.59 KB, patch)
2002-11-21 02:30 EST, udippel
no flags Details | Diff

  None (edit)
Description udippel 2002-11-20 03:45:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Sorry, guys, I didn't buy that machine (notebook, Type N222S) ... but around
here (South-East-Asia) we use to have such.
Inserting the RH8.0 CDROM install freezes completely (Power-off is only remedy)
at "Initializing PC Card Devices ..."
Bugzilla says something about earlier kernel problem ...
I tried 7.3 and 7.2, both with same results.
"boot: linux nopcmcia"
with RH8.0 freezing again just after the skipped card, while 7.3 goes through to
the installer with this option.
I checked on the first partition (blinding XP-luna) and the device shows up as 
02Micro OZ6912 CardBus Controller
(nothing forced)

Accepted, maybe no kernel support for that card, but somehow we should be able
to switch off all unsupported devices and do a clean install of everything else.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert CDROM and start
2. Wait

Actual Results:  freeze

Expected Results:  anaconda goes through
more specific: it should not freeze after the nopcmcia-switch with a blue screen
(hihihi) and no further hint.
RH8.0 should be more forgiving than 7.3, by the way.

Additional info:
Comment 1 Arjan van de Ven 2002-11-20 10:08:46 EST
is this a machine with a Radeon IGP chipset ?
Comment 2 udippel 2002-11-21 02:27:25 EST
I dunno. But please find the lspci includeed.

Btw, it booted after install, but once again tried to start pcmcia(d).
With linux rescue nopcmcia I could get into chroot, start ntsysv and clear it out.
Now it starts nicely !
Comment 3 udippel 2002-11-21 02:30:02 EST
Created attachment 85865 [details]
This is the lspci -v output. You might get some info from it ...?
Comment 4 udippel 2002-11-21 03:20:30 EST
After all those troubles I could say a nice thing to you, guys:
The performance of RH7.3 is above my expectations:
Video-card and screen work nicely, automatic detection
Sound works nicely, automatic detection
NIC works nicely, automatic detection
CDROM is on friendly automount, nice
one and only minor inconvenience: the touchpad - recognized nicely during
install - is horribly dead after reboot. So I had to recommend a USB-mouse
(works nicely, automatic detection, you know the thing by now)
Comment 5 Alan Cox 2002-11-21 08:32:23 EST
Sounds like the pcmcia scan is touching some register space that offends this
specific laptop. 8.0 might be triggering it due to the isapnp scan, you may find
adding "noisapnp" helps.

With regards to the touchpad, try disabling kudzu on startup and rebooting. You
may find that brings your touchpad back to life. Let me know if it does
Comment 6 udippel 2002-11-21 11:07:24 EST
It is not mine and I don't have it here, but I'll ask the owner to try the

With respect to the pcmcia:
1. Where, precisely, should I add noisapnp? Install; where I had put nopcmcia?
2. Is it buggy when the nopcmcia-install activates the pcmciad? Personally I'd
think so; firstly it misses out on logic and secondly, it rendered the whole
thing unusable if not for a rather complicated rescue with chroot and ntsysv;
out of reach for the everyday user.
Comment 7 Alan Cox 2002-11-21 11:49:30 EST
Should be isapnp=off - and yes same place as nopcmcia
Comment 8 udippel 2002-11-21 13:34:31 EST
For the mouse/kudzu: currently it is configured (kudzu) for a USB-mouse.
Should this config be removed before we try disable kudzu?
Will it be okay to remove kudzu with ntsysv from the services for the proposed test?
Comment 9 Rick Richardson 2002-12-01 09:10:23 EST
I bought a new Toshiba Satelllite 1115-S103 (very low cost notebook) a couple
days ago, and have the same
problem trying to load RH8.0. With no boot args, it freezes at "Initializing PC
Card Devices".  With boot args
"linux isapnp=off nopcmcia" it freezes with just a blue screen of death.  For a
minute, I thought Redhat was
trying to copy the MS look and feel just a bit too closely :-).

The Knoppix 3.1 Live CD boots fine on this machine, and even is able to load the
PCMCIA drivers without
crashing. I was also able to load Mandrake 9.0 as well.  But with Mandrake I had
to boot to single user on the second boot and neuter PCMCIA is
/etc/sysconfig/pcmcia.  Mandrake has other problems such as no power management
or battery status indications, so is really not an option.

Redhat 7.3 also freezes at "Initializing PC Card Devices" with no boot args. 
But with "nopcmcia" as the boot
arg, installation proceeds normally.  After installation, I have to boot to
single user and neuter the sysconfig file
as above to prevent crashes.  I then brought the system up to current rev level
with up2date and rebooted.

Just as the thread author reported, the touchpad mouse is non-functional, but
the USB mouse works.  On every
other distro that I tried on this laptop, the touchpad mouse and the USB mouse
were simultaneously active.
Disabling "kudzu" and rebooting had no effect, the touchpad mouse remained dead.
Comment 10 Bugzilla owner 2004-09-30 11:40:13 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.