Bug 782222 - kde-printer-applet-debuginfo is empty
kde-printer-applet-debuginfo is empty
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-printer-applet (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-16 16:18 EST by Ville Skyttä
Modified: 2012-01-17 08:04 EST (History)
6 users (show)

See Also:
Fixed In Version: kde-printer-applet-4.7.97-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-17 08:04:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2012-01-16 16:18:15 EST
kde-printer-applet-debuginfo 4.7.97-1 is empty.  Should the package be noarch?
Comment 1 Rex Dieter 2012-01-16 18:20:46 EST
It's contents certainly are all noarch, I'll have to doublecheck none of it's dependencies need to be arch'd before doing so.

OK, looks like we probably will need arch'd deps much like how system-config-printer's deps are handled as well.  I assume the same problem applies for system-config-printer wrt -debuginfo as well?
Comment 2 Rex Dieter 2012-01-16 19:48:31 EST
Yeah, mostly, except it does seem to include at least one binary helper for system-config-printer-udev, so system-config-printer-debuginfo isn't empty like ours.

I'm thinking we need 2 things then:
1. suppress -debuginfo generation
2. make Requires: arch'd properly
Comment 3 Kevin Kofler 2012-01-16 19:54:31 EST
kde-printer-applet should just be noarch. It's perfectly fine for a noarch package to have dependencies on arch-specific packages (just don't try to %{?_isa} them, obviously).
Comment 4 Rex Dieter 2012-01-16 20:29:14 EST
well, making the dependencies arch'd would be more correct.  For example, on a multilib'd x86_64 box, while kde-printer-applet works fine with pykde.x86_64, it won't with pykde.i686
Comment 5 Rex Dieter 2012-01-16 20:37:15 EST
that said, I'm ok with just noarch'ing it.  it's simpler and should work by default, unless someone goes out of their way to install non-native arch'd deps to break it.
Comment 6 Rex Dieter 2012-01-17 08:04:20 EST
ok, went with the noarch approach, fixed in 4.7.97-2

Note You need to log in before you can comment on or make changes to this bug.