Bug 78225 - [patch] First-time squid run crashes if no DNS
[patch] First-time squid run crashes if no DNS
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: squid (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-11-20 07:42 EST by Robin Green
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 15:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2002-11-20 07:42:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
When I ran squid for the first time it kept crashing on startup. I was not
online at the time. I traced the problem to a bug in startup script, see below.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Disconnect from network
2. Reinstall squid, deleting cache
3. Start squid
	

Actual Results:  Squid crashes when creating cache

Patch:

--- squid~      Thu Jul 18 09:49:56 2002
+++ squid       Wed Nov 20 12:30:20 2002
@@ -52,7 +52,7 @@
     for adir in $CACHE_SWAP; do
         if [ ! -d $adir/00 ]; then
             echo -n "init_cache_dir $adir... "
-            $SQUID -z -F 2>/dev/null
+            $SQUID -z -F -D 2>/dev/null
        fi
     done
     echo -n $"Starting $prog: "
Comment 1 Bill Nottingham 2003-01-15 15:58:24 EST
will be added in 2.5.STABLE1-1, thx!

Note You need to log in before you can comment on or make changes to this bug.