Bug 783239 - Resource listed in discovery queue even when it no longer exists
Resource listed in discovery queue even when it no longer exists
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
3.0.1
Unspecified Unspecified
high Severity unspecified (vote)
: GA
: RHQ 4.10
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 13:17 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 08:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2012-01-19 13:17:24 EST
Version-Release number of selected component (if applicable):
Version: 4.3.0-SNAPSHOT
Build Number: 7a155ea

How reproducible:always


Steps to Reproduce:
1. inventory EAP6 Domain controller, do NOT inventory managed servers
2. remove any of managed servers (use controller's operation)
3. run manual auto-discovery (detailed)
4. check discovery queue
  
Actual results: Managed servers that you deleted is still offered to import by agent 


Expected results:Discovery queue no longer offers deleted managed server, since it did not exist at time of last autodiscovery run.


Additional info:
Comment 1 Heiko W. Rupp 2012-01-23 11:17:29 EST
Afair, this works that way with every resource and is not as7 specific.

Start an as4, let it show up in discovery q, shut down the as4 and see it stay in the discovery q.

Currently the workaround is to take it into inventory and then directly uninventory it again.
Comment 2 Heiko W. Rupp 2012-04-11 07:42:53 EDT
Managed servers are no longer top level servers that show up in the discovery queue, so I remove this from the AS7-plugin tracker. This is a general UI issue that we basically have since forever.
Comment 3 Jay Shaughnessy 2013-11-20 09:05:02 EST
Please re-test given changes in the discovery queue implementation.  The changes for performance may have also solved this issue.

Setting to ON_QA for 4.10
Comment 4 Heiko W. Rupp 2014-04-23 08:31:43 EDT
Bulk closing of 4.10 issues.

If an issue is not solved for you, please open a new BZ (or clone the existing one) with a version designator of 4.10.

Note You need to log in before you can comment on or make changes to this bug.