Bug 78326 - KsCD Shuffle Play button does not work
KsCD Shuffle Play button does not work
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-21 09:27 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:00:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-21 09:27:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.18-18.7.x i686; Nav)

Description of problem:
The KsCD Shuffle Play button does not shuffle the tracks of the CD and, most of
the time, does not play either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert a music CD
2. Open KsCD if it doesn't automatically open
3. Press the Shuffle Play button
	

Actual Results:  Sometimes the Shuffle Play button will play the CD but the
tracks will not be shuffled. Most of the time, it will just flash the word
"Shuffle" in the display and then Pause the CD.

Expected Results:  Hitting the Shuffle Play button should cause a random track
of the CD to start playing.

Additional info:

This must be a fairly recent bug because it does't appear in my RedHat Linux 7.1
version of the cd player.
Comment 1 Ngo Than 2002-12-10 09:56:48 EST
could you please try kde-3.0.3 i current errata. Does it fix this problem?
Comment 2 Need Real Name 2002-12-12 12:59:14 EST
After applying all of the latest errata updates, the KsCD player works slightly
better (i.e. it plays CD's more consistently) but the shuffle feature still does
not work (i.e. the CD tracks always play in order). Pressing the "shuffle play"
button causes the word "Shuffle" to appear in the KsCD display but does not
start playing a random CD track as it should. Subsequently pressing the "play"
button causes the CD tracks to start playing in order and changes the display to
read "playing." Pressing the "Shuffle Play" button again changes the display to
read "Shuffle" but does not affect the playing CD.
Comment 3 Ngo Than 2002-12-13 07:17:41 EST
as i know the default kscd setting is "Shuffle order and play each song only once"
You should reconfifgure it for example "Ramdom select songs"
Comment 4 Need Real Name 2003-01-13 16:53:12 EST
The problem is not that I am looking for the random setting. Perhaps I should
re-state the exact problem. On my RedHat Linux 7.1 box, loading a CD into the
CD-ROM and then pressing the "Shuffle Play" button in KsCD caused a track of the
CD to immediately start playing. The track that started playing was not always
track 1 (i.e. the tracks were shuffled). Each track preceeded to play exactly
once but not in numerical order. That seems to be how the "Shuffle Play" button
should work. Now, in RedHat Linux 7.3, loading a CD into the CD-ROM and then
pressing the "Shuffle Play" button only causes a message to display: "No
matching freedb entry found." No track of the CD starts playing, not even track
1. Subsequently pressing the "Play" button causes track 1 to start playing
(followed by track 2 and track 3, etc.) So, there are two problems here:
1) The "Shuffle Play" button does not shuffle the CD tracks. They are still
ordered 1, 2, 3, ...
2) The "Shuffle Play" button does not play any CD tracks. 
Comment 5 Petr Rockai 2006-07-17 14:18:16 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 6 Bill Nottingham 2006-10-18 14:00:13 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.