Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 783506 - FTBFS on rawhide with gcc 4.7
FTBFS on rawhide with gcc 4.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 11:54 EST by Peter Robinson
Modified: 2012-03-26 13:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: elfutils-0.153-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 20:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-01-20 11:54:05 EST
elfutils doesn't compile with gcc 4.7 on rawhide.

http://koji.fedoraproject.org/koji/buildinfo?buildID=284696

Looks like this patch might be relevant

http://lists.linuxtogo.org/pipermail/openembedded-core/2011-July/005615.html
Comment 1 Roland McGrath 2012-01-20 13:58:38 EST
This was already fixed upstream.  It's probably about time for an 0.153 release.
Comment 2 Mark Wielaard 2012-01-20 14:32:13 EST
The upstream fix is:
http://git.fedorahosted.org/git/?p=elfutils.git;a=commitdiff;h=32899ac4f69d4ca4856d5282464c1f9cee928c8a
I'll prepare a backport to get elfutils to build again.

But I agree that it is about time for a new upstream release.
Comment 3 Mark Wielaard 2012-01-20 15:44:24 EST
I pushed a build, which compiled, but failed one of the testcases:

section [35] '.symtab': symbol 137: st_value out of bounds
*** failure in ../src/addr2line
section [36] '.symtab': symbol 310: st_value out of bounds
*** failure in ../libelf/libelf.so
FAIL: run-elflint-self.sh

See http://koji.fedoraproject.org/koji/getfile?taskID=3718849&name=build.log

Will need to investigate on a rawhide install to see what is going on.
Comment 4 Mark Wielaard 2012-01-20 15:47:17 EST
Note this is x86_64 specific, the i686 build succeeded with all tests PASS:
http://koji.fedoraproject.org/koji/getfile?taskID=3718850&name=build.log
Comment 5 Peter Robinson 2012-01-21 09:11:47 EST
(In reply to comment #4)
> Note this is x86_64 specific, the i686 build succeeded with all tests PASS:

Builds on armv7hl and armv5tel without problems as well.
Comment 6 Mark Wielaard 2012-01-23 04:59:18 EST
(In reply to comment #3)
> I pushed a build, which compiled, but failed one of the testcases:
> 
> section [35] '.symtab': symbol 137: st_value out of bounds
> *** failure in ../src/addr2line
> section [36] '.symtab': symbol 310: st_value out of bounds
> *** failure in ../libelf/libelf.so
> FAIL: run-elflint-self.sh
> 
> See http://koji.fedoraproject.org/koji/getfile?taskID=3718849&name=build.log
> 
> Will need to investigate on a rawhide install to see what is going on.

This is about the new __TMC_END__ symbol, see upstream discussion here: https://fedorahosted.org/pipermail/elfutils-devel/2012-January/002197.html
Comment 7 Peter Robinson 2012-02-13 10:15:31 EST
(In reply to comment #1)
> This was already fixed upstream.  It's probably about time for an 0.153
> release.

What's the status on a 0.153 release?
Comment 8 Mark Wielaard 2012-02-13 10:22:18 EST
(In reply to comment #7)
> What's the status on a 0.153 release?

See this thread: https://fedorahosted.org/pipermail/elfutils-devel/2012-February/002221.html
It looks good to go unless any new show stoppers are found.
Comment 9 Mark Wielaard 2012-02-23 08:21:42 EST
elfutils 0.153 has been released:
https://fedorahosted.org/pipermail/elfutils-devel/2012-February/002231.html

It has also been successfully build in rawhide/f18:
http://koji.fedoraproject.org/koji/buildinfo?buildID=301120

But still fails to build on f17:
http://koji.fedoraproject.org/koji/buildinfo?buildID=301124

Because the fixed binutils release doesn't seem to be available in the f17 even though that too has been successfully build for f17:
http://koji.fedoraproject.org/koji/buildinfo?buildID=299699

So the wait is now on getting binutils-2.22.52.0.1-5.fc17 actually in the f17 build roots and then we can rebuild elfutils-0.153-1.fc17 against it.
Comment 10 Mark Wielaard 2012-02-24 07:24:24 EST
New binutils is very slowly making its way through bodhi, testing, updates, etc... https://admin.fedoraproject.org/updates/FEDORA-2012-2260/binutils-2.22.52.0.1-5.fc17
Comment 11 Peter Robinson 2012-02-24 09:52:23 EST
Mark: you do know you can tag the new binutils into a build override to build the new elfutils?
Comment 12 Mark Wielaard 2012-02-24 09:57:59 EST
(In reply to comment #11)
> Mark: you do know you can tag the new binutils into a build override to build
> the new elfutils?

No I didn't :) How please?
Comment 13 Peter Robinson 2012-02-24 10:07:38 EST
(In reply to comment #12)
> (In reply to comment #11)
> > Mark: you do know you can tag the new binutils into a build override to build
> > the new elfutils?
> 
> No I didn't :) How please?

Login to https://admin.fedoraproject.org/updates/

On the left hand side there's an option "Buildroot Overrides" and you can specify the NVR you want and how long you need it for. It then takes around 30 mins to get into the F-17 buildroot and you can build against it.
Comment 14 Mark Wielaard 2012-02-24 10:16:44 EST
(In reply to comment #13)
> Login to https://admin.fedoraproject.org/updates/
> 
> On the left hand side there's an option "Buildroot Overrides" and you can
> specify the NVR you want and how long you need it for. It then takes around 30
> mins to get into the F-17 buildroot and you can build against it.

That only seems to work if you also have commit privs for the package you want an override for. "Error: You do not have commit privileges to binutils"

But I saw the update just got enough votes to get pushed through, so it should be there tomorrow or after the weekend. Will try a rebuild then.
Comment 15 Fedora Update System 2012-02-24 10:23:03 EST
elfutils-0.153-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/elfutils-0.153-1.fc16
Comment 16 Peter Robinson 2012-02-24 10:27:03 EST
> That only seems to work if you also have commit privs for the package you want
> an override for. "Error: You do not have commit privileges to binutils"

I've tagged it in for you. Should be in the F-17 buildroot in around 20 mins. So give it maybe 30 to be sure and your good to build.
Comment 17 Fedora Update System 2012-02-24 11:03:07 EST
elfutils-0.153-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/elfutils-0.153-1.fc17
Comment 18 Fedora Update System 2012-02-24 17:32:56 EST
Package elfutils-0.153-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing elfutils-0.153-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2344/elfutils-0.153-1.fc17
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2012-03-01 20:19:08 EST
elfutils-0.153-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2012-03-10 08:06:13 EST
elfutils-0.153-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/elfutils-0.153-1.fc15
Comment 21 Fedora Update System 2012-03-10 16:53:40 EST
elfutils-0.153-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2012-03-25 23:55:31 EDT
elfutils-0.153-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2012-03-26 13:59:02 EDT
elfutils-0.153-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.