Bug 783718 - Cannot compile a C99 program
Cannot compile a C99 program
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-21 19:37 EST by Fred J. Tydeman
Modified: 2012-02-04 00:32 EST (History)
5 users (show)

See Also:
Fixed In Version: llvm-2.9-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-04 00:32:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred J. Tydeman 2012-01-21 19:37:52 EST
Description of problem:
The linker cannot find several files: 
  crt1.o crti.o crtbegin.o -lgcc -lgcc_s

Version-Release number of selected component (if applicable):
2.9-4

How reproducible:
Always
  
Steps to Reproduce:
1. Add clang and llvm products to 32-bit Fedora Core 16 system.  
2. Try to compile, link and run any C99 program: clang -std=c99 hello.c
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Fred J. Tydeman 2012-01-21 19:45:48 EST
When I reported this bug to http://llvm.org/bugs/
they told me that 2.9-4 is out of date and that I should
upgrade to a newer version of clang/llvm.
So, can we get a current version of clang for Fedora?
Comment 2 Michel Alexandre Salim 2012-02-02 03:58:40 EST
Apologies, that's due to the GCC update (clang < 3.0 is hard-coded to pick up files from the GCC it's compiled against).

Will be fixed in -6, please help test.
Comment 3 Fedora Update System 2012-02-02 04:04:32 EST
llvm-2.9-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/llvm-2.9-6.fc16
Comment 4 Fedora Update System 2012-02-02 12:26:08 EST
Package llvm-2.9-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing llvm-2.9-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1188/llvm-2.9-6.fc16
then log in and leave karma (feedback).
Comment 5 Fred J. Tydeman 2012-02-02 18:50:33 EST
After doing the above update, I now can compile, link, and run C99 programs.
Thanks.

I tried do the above karma, but I believe I do not have a valid id/password.

Any chance that clang 3.0 will be made available to Add/Install?
Comment 6 Michel Alexandre Salim 2012-02-03 05:07:01 EST
Thanks for confirming! To leave a karma, you need an account from https://admin.fedoraproject.org/accounts -- anyone can get an account that let them vote in Bodhi, I believe (you just need a verified email, which you do for Bugzilla anyway). We don't have a unified account system for Bugzilla yet, alas.

For clang 3.0 you'd need to move to Fedora 17 when it's released. We use LLVM (to which clang is tied) for major parts of our infrastructure, so breaking updates post-release are not appropriate.
Comment 7 Fedora Update System 2012-02-04 00:32:22 EST
llvm-2.9-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.