Bug 784060 - Unable to install Deltacloud-core-all on Fedora 14 and 15 version due to the lack of rubygem-fog for these versions
Unable to install Deltacloud-core-all on Fedora 14 and 15 version due to the ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: deltacloud-core (Show other bugs)
14
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michal Fojtik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-23 12:22 EST by Ramesh A
Modified: 2012-08-16 10:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 10:41:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ramesh A 2012-01-23 12:22:36 EST
Description of problem:

Unable to install Deltacloud-core-all on Fedora 14 and 15 versions.  This is because, the dependency rubygem-fog rpm packages are not available for these OS.

Version-Release number of selected component (if applicable):
Deltacloud API 0.5.0 

How reproducible:

[root@server ~]# yum  install deltacloud-core-all
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
http://repos.fedorapeople.org/repos/aeolus/conductor/0.3.0/fedora-14/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 : http://repos.fedorapeople.org/repos/aeolus/conductor/0.3.0/fedora-14/x86_64/repodata/repomd.xml 
Trying other mirror.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package deltacloud-core-all.noarch 0:0.5.0-0.rc1.fc14 will be installed
--> Processing Dependency: deltacloud-core = 0.5.0-0.rc1.fc14 for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-rimuhosting for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-opennebula for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-openstack for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-vsphere for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-gogrid for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-eucalyptus for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-rhevm for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-rackspace for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-ec2 for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-sbc for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Processing Dependency: deltacloud-core-google for package: deltacloud-core-all-0.5.0-0.rc1.fc14.noarch
--> Running transaction check
---> Package deltacloud-core.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-ec2.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-eucalyptus.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-gogrid.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-google.noarch 0:0.5.0-0.rc1.fc14 will be installed
--> Processing Dependency: rubygem(fog) for package: deltacloud-core-google-0.5.0-0.rc1.fc14.noarch
---> Package deltacloud-core-opennebula.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-openstack.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-rackspace.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-rhevm.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-rimuhosting.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-sbc.noarch 0:0.5.0-0.rc1.fc14 will be installed
---> Package deltacloud-core-vsphere.noarch 0:0.5.0-0.rc1.fc14 will be installed
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: deltacloud-core-google-0.5.0-0.rc1.fc14.noarch (deltacloud-core)
           Requires: rubygem(fog)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@server ~]#
Comment 1 Fedora End Of Life 2012-08-16 10:41:09 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.