Bug 784304 - Enhance internal testsuite to emit exit code != 0 on error
Enhance internal testsuite to emit exit code != 0 on error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: indent (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Petr Pisar
qe-baseos-tools
http://lists.gnu.org/archive/html/bug...
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 09:17 EST by Michal Nowak
Modified: 2013-03-07 21:13 EST (History)
3 users (show)

See Also:
Fixed In Version: indent-2.2.10-7.el6
Doc Type: Bug Fix
Doc Text:
Cause Running package test-suite with broken indent code. Consequence Internal test-suite does not signal test failure by exit code. Fix An call to exit with non-zero code has been added into internal test-suite in failure-branch. Result If internal test-suite does not pass, non-zero code will be returned.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (589 bytes, patch)
2012-02-02 11:24 EST, Petr Pisar
no flags Details | Diff

  None (edit)
Comment 1 Petr Pisar 2012-02-02 11:24:56 EST
Created attachment 559079 [details]
Proposed fix
Comment 3 Petr Pisar 2012-02-07 09:20:31 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Running package test-suite with broken indent code.
Consequence
    Internal test-suite does not signal test failure by exit
    code.
Fix
    An call to exit with non-zero code has been added into
    internal test-suite in failure-branch.
Result
    If internal test-suite does not pass, non-zero code will
    be returned.
Comment 7 errata-xmlrpc 2012-06-20 08:00:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0753.html

Note You need to log in before you can comment on or make changes to this bug.