This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 784668 - suspend to ram switch of intel video till reboot the host
suspend to ram switch of intel video till reboot the host
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 13:33 EST by Sergei LITVINENKO
Modified: 2012-03-01 13:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 13:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Dmesg info after boot and after suspend to ram (75.08 KB, application/x-tar)
2012-01-28 07:28 EST, Sergei LITVINENKO
no flags Details
config-3.1.9-1.fc16.i686.PAE without debug (debug is switched off) (29.49 KB, application/x-gzip)
2012-01-29 06:31 EST, Sergei LITVINENKO
no flags Details

  None (edit)
Description Sergei LITVINENKO 2012-01-25 13:33:09 EST
Description of problem:
After suspend to RAM host keep screen blank till reboot.


Version-Release number of selected component (if applicable):
3.2.1-3.fc16.i686.PAE


How reproducible:
100%


Steps to Reproduce:
1. Boot host HP 2540p
2. login by kdm (gdm too) to KDM
3. Ment,  Exit, Suspend to RAM
4. Press power buttom.
5. Wait till resume.
6. Look at the screen.
  
Actual results:
Screen is blank.

Expected results:
Graphics screen with prompt to type password

Additional info:
1. vmlinuz-3.1.8-2.fc16.i686.PAE is not affected. Under this kernel suspend/resume work as expected.
vmlinuz-3.1.9-1.fc16.i686.PAE is affected.
vmlinuz-3.2.1-3.fc16.i686.PAE is affected.

2. Host is accessible by SSH
3. Reboot from SSH session do not restore screen. It is necessary to switch off host `shutdown -h now`

[root@ua-dudn00000 ~]# lshw
ua-dudn00000              
    description: Notebook
    product: HP EliteBook 2540p (WK304EA#ACB)
    vendor: Hewlett-Packard
    serial: CZC038B8ZZ
    width: 32 bits
    capabilities: smbios-2.6 dmi-2.6
    configuration: boot=normal chassis=notebook family=103C_5336AN sku=WK304EA#ACB uuid=219EB521-01C9-DF11-83E4-E2008F06C0E5
  *-core
       description: Motherboard
       product: 7008
       vendor: Hewlett-Packard
       physical id: 0
       version: KBC Version 38.2E
       serial: xxxxxxxxx
     *-firmware
          description: BIOS
          vendor: Hewlett-Packard
          physical id: 9
          version: 68CSU Ver. F.03
          date: 05/25/2010
          size: 64KiB
          capacity: 3008KiB
          capabilities: pci pcmcia upgrade shadowing cdboot bootselect edd int5printscreen int9keyboard int14serial int17printer acpi usb smartbattery biosbootspecification netboot
...
Comment 1 Josh Boyer 2012-01-25 13:59:30 EST
(In reply to comment #0)
> Description of problem:
> After suspend to RAM host keep screen blank till reboot.
> 
> 
> Version-Release number of selected component (if applicable):
> 3.2.1-3.fc16.i686.PAE
> 
> 
> How reproducible:
> 100%
> 
> 
> Steps to Reproduce:
> 1. Boot host HP 2540p
> 2. login by kdm (gdm too) to KDM
> 3. Ment,  Exit, Suspend to RAM
> 4. Press power buttom.
> 5. Wait till resume.
> 6. Look at the screen.
> 
> Actual results:
> Screen is blank.
> 
> Expected results:
> Graphics screen with prompt to type password
> 
> Additional info:
> 1. vmlinuz-3.1.8-2.fc16.i686.PAE is not affected. Under this kernel
> suspend/resume work as expected.
> vmlinuz-3.1.9-1.fc16.i686.PAE is affected.
> vmlinuz-3.2.1-3.fc16.i686.PAE is affected.

There was a recent upstream bug report where commit cd9dde44f475013 was causing this exact behavior on the same kind of laptop.  That commit is in 3.2.x, but  it isn't in 3.1.x from what I can see.  Are you sure 3.1.9 is broken with resume in the same way?
Comment 2 Sergei LITVINENKO 2012-01-25 14:30:25 EST
>> Are you sure 3.1.9 is broken with resume in the same way?

Yes, I'm sure.

PS: I have deleted 3.1.9 as soon as report was send, because 3 kernels are installed and next update will delete kernel, which work correct. If 3.1.9 would be correct, I would keep this one.
Comment 3 Sergei LITVINENKO 2012-01-28 07:28:16 EST
Created attachment 558044 [details]
Dmesg info after boot and after suspend to ram

Also,

1/ 3.2.2-1.fc16.i686.PAE do not fix issue.

2/ Host accessible by SSH

3/ Issue is not related to xorg (as minimum, directly), because
   `echo -n mem > /sys/power/state`
   from runlevel 3 cause the same problem as syspend to ram from KDE menu.

4/ Backlight of screen can be changed by sysfs. Screen still blank, but
`echo "8" > /sys/devices/pci0000:00/0000:00:02.0/backlight/acpi_video0/brightness` change backlight (default value is 24)

5/ All other components like work as expected.
Comment 4 Sergei LITVINENKO 2012-01-28 07:46:21 EST
Notebook has 2 external interfaces for video - VGA and Display port.

How to check what interface is active?

Is it possible, that suspend to ram force activating of VGA or Display Port and it switch video to wrong interface? 

How to check it without external monitor with VGA and Display Port interfaces?
Comment 5 Sergei LITVINENKO 2012-01-29 06:31:12 EST
Created attachment 558144 [details]
config-3.1.9-1.fc16.i686.PAE without debug (debug is switched off)

Vanilla-3.1.10 (sources from http://www.kernel.org/) with small changes of config-3.1.9-1.fc16.i686.PAE (only debug is switched off) is not affected to issue.
Comment 6 Sergei LITVINENKO 2012-02-25 10:56:48 EST
In 3.2.7-1.fc16.i686.PAE issue is solved.

Note You need to log in before you can comment on or make changes to this bug.