This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 785843 - [rhevm] [admin-portal] rhevm should report libvirt version in host tab - general sub tab
[rhevm] [admin-portal] rhevm should report libvirt version in host tab - gene...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
x86_64 Windows
unspecified Severity high
: ---
: 3.2
Assigned To: Alexey Chub
infra
: Improvement
Depends On: 672148 672149 889045
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-30 13:45 EST by David Jaša
Modified: 2013-03-20 02:19 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 672149
Environment:
Last Closed: 2013-02-15 01:46:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-01-30 13:45:45 EST
+++ This bug was initially created as a clone of Bug #672149 +++

+++ This bug was initially created as a clone of Bug #672148 +++

Description of problem:

we are currently reporting the following packages: 

vdsm, qemu-kvm, spice, etc.

we should also report libvirt version. 
please note that vdsm report the correct version in getVdsCaps, backend should store it in data-base, and GUI should present it. 
I will open another bug for GUI with dependency for this bug. 

[root@nott-vds1 ~]# vdsClient -s 0 getVdsCaps |grep --color libvirt
        packages2 = {'kernel': {'release': '71.7.1.el6.x86_64', 'buildtime': '0', 'version': '2.6.32'}, 'spice-server': {'release': '15.el6', 'buildtime': '1280936485', 'version': '0.4.2'}, 'vdsm': {'release': '43.1.gcdf032.vmRaise', 'buildtime': '1295535675', 'version': '4.9'}, 'qemu-kvm': {'release': '2.129.el6', 'buildtime': '1294691876', 'version': '0.12.1.2'}, 'libvirt': {'release': '3.el6', 'buildtime': '1295553950', 'version': '0.8.7'}, 'qemu-img': {'release': '2.129.el6', 'buildtime': '1294691876', 'version': '0.12.1.2'}} 

double checked database, db_vds_dynamic table, and there is no column for libvirt version.

--- Additional comment from yeylon@redhat.com on 2011-06-22 09:20:05 CEST ---

*** Bug 715002 has been marked as a duplicate of this bug. ***
Comment 1 Itamar Heim 2012-10-28 06:21:25 EDT
http://gerrit.ovirt.org/#/c/8635/
Comment 2 Itamar Heim 2013-01-16 11:09:53 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.