This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 785995 - Error when installing katello-headpin-all
Error when installing katello-headpin-all
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 703617
  Show dependency treegraph
 
Reported: 2012-01-31 00:42 EST by Hui Wang
Modified: 2012-02-09 12:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-31 04:51:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-01-31 00:42:06 EST
Description of problem:

It reports some error infos when install katello-headpin-all via setting the sam.repo's baseurl=http://download.lab.bos.redhat.com/rel-eng/CloudForms/SubscriptionAssetManager/1.0/2012-01-30.1/x86_64.


Version-Release number of selected component (if applicable):
katello-configure-0.1.55-2.el6.noarch
katello-headpin-all-0.1.129-2.el6.noarch
katello-cli-common-0.1.40-2.el6.noarch
katello-trusted-ssl-cert-1.0-1.noarch
katello-glue-candlepin-0.1.200-2.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-common-0.1.200-2.el6.noarch
katello-httpd-ssl-key-pair-1.0-1.noarch
katello-cli-headpin-0.1.15-2.el6.noarch
katello-certs-tools-1.0.2-2.el6.noarch
katello-headpin-0.1.129-2.el6.noarch
candlepin-tomcat6-0.5.14-1.el6.noarch
katello-glue-candlepin-0.1.200-2.el6.noarch
candlepin-0.5.14-1.el6.noarch
thumbslug-0.0.21-1.el6.noarch

How reproducible:

always
Steps to Reproduce:

       1. Prepare one machine (physical/VM) installed RHEL6 Server. Register the system and consume a "Red Hat Enterprise Linux Server" subscription.
       2. Open port 443, 8443 for HTTPS (Secure WWW) connections to Katello and 8088 for thumbslug.
          a. Method one: set  Secure WWW to be trusted.
              # system-config-firewall-tui
          b. Method two: add the following line before the "-A INPUT -j REJECT --reject-with icmp-host-prohibited" line within file /etc/sysconfig/iptables
              -A INPUT -p tcp -m state --state NEW -m tcp --dport 443 -j ACCEPT
              -A INPUT -p tcp -m state --state NEW -m tcp --dport 8443 -j ACCEPT
              -A INPUT -m state --state NEW -m tcp -p tcp --dport 8088 -j ACCEPT
              # vi /etc/sysconfig/iptables
              # service iptables restart
       3. Configure repos.
          a. Enable optional repo.
              # yum repolist
              # yum-config-manager --enable rhel-6-server-optional-rpms
          b. Add SAM repo.
              # vi /etc/yum.repos.d/sam.repo
              [sam]
              name = sam
              baseurl = http://download.lab.bos.redhat.com/rel-eng/CloudForms/SubscriptionAssetManager/1.0/2012-01-30.1/x86_64/
              enabled = 1
              gpgcheck = 0
        4. Change hostname and add it to /etc/hosts.
             # hostname $MACHINENAME
             # vi /etc/hosts
             $IP  $MACHINENAME
        5. Installation

        # yum install -y katello-headpin-all

          ............
        Error: Package: rubygem-sexp_processor-3.0.4-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-eventmachine-0.12.10-3.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: katello-headpin-all-0.1.129-2.el6.noarch (sam)
           Requires: postgresql
Error: Package: rubygem-erubis-2.6.6-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: ruby-devel-1.8.7.352-3.el6.x86_64 (rhel-6-server-optional-rpms)
           Requires: ruby-libs = 1.8.7.352-3.el6
Error: Package: rubygem-pg-0.11.0-5.el6.x86_64 (sam)
           Requires: ruby
Error: Package: 1:rubygem-actionpack-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-railties-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rubyforge-2.0.4-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rake-0.9.2-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: 1:rubygem-rails-3.0.10-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-rack-test-0.5.4-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-oauth-0.4.4-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-hoe-2.6.2-2.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-activemodel-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: facter-1.5.9-1.el6.noarch (sam)
           Requires: ruby >= 1.8.1
Error: Package: rubygem-jammit-0.5.4-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-bundler-1.0.15-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-ruby_parser-2.0.4-4.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: 1:rubygem-rails-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-ruby2ruby-1.2.4-2.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-maruku-0.6.0-4.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: 1:rubygem-actionmailer-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: katello-headpin-all-0.1.129-2.el6.noarch (sam)
           Requires: postgresql-server
Error: Package: puppet-2.6.11-1.el6_1.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: katello-certs-tools-1.0.2-2.el6.noarch (sam)
           Requires: rpm-build
Error: Package: rubygem-haml-3.1.2-2.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-json-1.4.6-3.el6.x86_64 (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-fast_gettext-0.5.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-multi_json-1.0.3-1.el6.noarch (sam)
           Requires: ruby
Error: Package: rubygem-thin-1.2.11-3.el6.x86_64 (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-jammit-0.5.4-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-color-1.4.1-5.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-compass-0.11.5-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-maruku-0.6.0-4.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-acts_as_reportable-1.1.1-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-compass-960-plugin-0.10.4-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-pdf-writer-1.1.8-3.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: ruby-rdoc-1.8.7.352-3.el6.x86_64 (rhel-6-server-optional-rpms)
           Requires: ruby-irb = 1.8.7.352-3.el6
           Available: ruby-irb-1.8.7.299-4.el6.x86_64 (rhel-6-server-optional-rpms)
               ruby-irb = 1.8.7.299-4.el6
           Available: ruby-irb-1.8.7.299-5.el6_0.1.x86_64 (rhel-6-server-optional-rpms)
               ruby-irb = 1.8.7.299-5.el6_0.1
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: augeas-libs >= 0.5.1
Error: Package: 1:rubygem-rack-1.3.0-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-hoe-2.6.2-2.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-treetop-1.4.9-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-gettext_i18n_rails-0.2.13-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-compass-0.11.5-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-polyglot-0.2.5-5.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-tire-0.3.12-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: puppet-2.6.11-1.el6_1.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: libaugeas.so.0(AUGEAS_0.1.0)(64bit)
Error: Package: rubygem-syntax-1.0.0-4.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-pg-0.11.0-5.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-ruby2ruby-1.2.4-2.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-arel-2.0.9-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-regin-0.3.7-3.el6.noarch (sam)
           Requires: ruby
Error: Package: katello-common-0.1.200-2.el6.noarch (sam)
           Requires: mod_ssl
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-multimap-1.1.2-3.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rack-mount-0.7.1-6.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: katello-common-0.1.200-2.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-json-1.4.6-3.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-eventmachine-0.12.10-3.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-treetop-1.4.9-1.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: 1:rubygem-activerecord-3.0.10-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-warden-1.0.5-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: 1:rubygem-activeresource-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: facter-1.5.9-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-daemons-1.1.4-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-hpricot-0.8.4-1.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-multimap-1.1.2-3.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-haml-3.1.2-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: candlepin-tomcat6-0.5.14-1.el6.noarch (sam)
           Requires: tomcat6
Error: Package: facter-1.5.9-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rails_warden-0.5.5-1.el6.noarch (sam)
           Requires: ruby
Error: Package: rubygems-1.7.2-1.el6.noarch (sam)
           Requires: ruby >= 1.8.7
Error: Package: rubygem-sass-3.1.4-4.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-fastercsv-1.5.1-2.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-multi_json-1.0.3-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygems-1.7.2-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-rails_warden-0.5.5-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-regin-0.3.7-3.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-ruport-1.6.3-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: libaugeas.so.0()(64bit)
Error: Package: rubygem-abstract-1.0.0-3.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-transaction-simple-1.4.0-4.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-tzinfo-0.3.26-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-closure-compiler-0.3.3-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-uuidtools-2.1.1-2.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-diff-lcs-1.1.2-4.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-pdf-writer-1.1.8-3.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-delayed_job-2.1.4-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-pg-0.11.0-5.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: 1:rubygem-rack-1.3.0-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-ParseTree-3.0.5-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-thin-1.2.11-3.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-yard-0.7.2-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-thor-0.14.6-2.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-sass-3.1.4-4.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: log4j-1.2.16-4_redhat_1.el6.noarch (sam)
           Requires: jaxp_parser_impl
Error: Package: ruby-rdoc-1.8.7.352-3.el6.x86_64 (rhel-6-server-optional-rpms)
           Requires: /usr/bin/ruby
Error: Package: rubygem-bundler-1.0.15-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-yard-0.7.2-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: puppet-2.6.11-1.el6_1.noarch (sam)
           Requires: ruby >= 1.8.1
Error: Package: rubygem-i18n-0.5.0-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-pg-0.11.0-5.el6.x86_64 (sam)
           Requires: libpq.so.5()(64bit)
Error: Package: rubygem-delayed_job-2.1.4-1.el6.noarch (sam)
           Requires: ruby
Error: Package: rubygem-ZenTest-4.3.3-1.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-ZenTest-4.3.3-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-diff-lcs-1.1.2-4.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-mime-types-1.16-4.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-haml-rails-0.3.4-3.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-RubyInline-3.8.4-1.el6_0.noarch (sam)
           Requires: gcc
Error: Package: rubygems-1.7.2-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-ParseTree-3.0.5-1.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-mail-2.3.0-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-thin-1.2.11-3.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-erubis-2.6.6-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-yui-compressor-0.9.1-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-i18n_data-0.2.7-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-net-ldap-0.1.1-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rake-0.9.2-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: 1:rubygem-activesupport-3.0.10-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-oauth-0.4.4-1.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-thor-0.14.6-2.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: katello-configure-0.1.55-2.el6.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-json-1.4.6-3.el6.x86_64 (sam)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-chunky_png-1.2.0-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-rest-client-1.6.1-2.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
Error: Package: rubygem-fastercsv-1.5.1-2.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-fssm-0.2.7-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-devel-1.8.7.352-3.el6.x86_64 (rhel-6-server-optional-rpms)
           Requires: libruby.so.1.8()(64bit)
Error: Package: rubygem-RubyInline-3.8.4-1.el6_0.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-sass-3.1.4-4.el6.noarch (sam)
           Requires: ruby
Error: Package: rubygem-hpricot-0.8.4-1.el6.x86_64 (sam)
           Requires: ruby(abi) = 1.8
Error: Package: rubygem-simple-navigation-3.3.4-1.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: log4j-1.2.16-4_redhat_1.el6.noarch (sam)
           Requires: mx4j
Error: Package: rubygem-ruby_parser-2.0.4-4.el6.noarch (sam)
           Requires: ruby(abi) = 1.8
Error: Package: ruby-augeas-0.3.0-1.el6.x86_64 (sam)
           Requires: libaugeas.so.0(AUGEAS_0.8.0)(64bit)
Error: Package: rubygem-rubyforge-2.0.4-1.el6_0.noarch (sam)
           Requires: /usr/bin/ruby
  
Actual results:

It is report some error when install katello-headpin-all

Expected results:
The katello-headpin-all can be installed successfully.
Comment 1 Hui Wang 2012-01-31 04:51:16 EST
Do not enable the rhel-6-server-rpms repo before installing.
Mark Not bug.

Note You need to log in before you can comment on or make changes to this bug.