Bug 786018 - Reconciliation problems after updating Eclipse
Reconciliation problems after updating Eclipse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-31 03:13 EST by Alexander Kurtakov
Modified: 2014-01-12 19:26 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-27 08:21:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2012-01-31 03:13:52 EST
Trying to start the help system I get:
HTTP ERROR: 404

Problem accessing /help/index.jsp. Reason:

    ProxyServlet: /help/index.jsp
Powered by Jetty://

Eclipse rpm version:
eclipse-3.8.0-0.M4c.fc17.src.rpm
Comment 1 Krzysztof Daniel 2012-01-31 04:00:32 EST
The problem does not seem to be caused by the build itself, I think it is a reconciliation problem.

Do get the 3.8.0 working, it is necessary to remove all existing eclipse packages and remove local ~/.eclipse folder to allow for fresh installation.
Comment 2 Andrew Overholt 2012-01-31 09:50:47 EST
(In reply to comment #1)
> Do get the 3.8.0 working, it is necessary to remove all existing eclipse
> packages and remove local ~/.eclipse folder to allow for fresh installation.

Is there any way we can avoid this?  I had hoped 3.8/4.2 would use a different directory under ~/.eclipse ...
Comment 3 Krzysztof Daniel 2012-01-31 10:13:14 EST
Actually inside .eclipse there is a folder with a generated name (timestamp or something). I could investigate if it can be improved (at least for our purposes).
Comment 4 Alexander Kurtakov 2012-03-07 07:37:13 EST
Chris, 
what is the state of this one?
The help system works just fine. Either close the bug or change the summary or open a new one about the .eclipse/versioned_lib thing.
Comment 5 Krzysztof Daniel 2012-03-07 09:32:32 EST
changed the title of the bug to reflect the real problem.

I'm afraid that I'll be able to address the bug only after making P2 cooperating with rpm.
Comment 6 Alexander Kurtakov 2013-02-26 10:50:57 EST
Chris, can we close this now?
Comment 7 Krzysztof Daniel 2013-02-26 11:06:43 EST
I think this is pretty much done but I'd like to conduct some testing here.
On my todo list.
Comment 8 Krzysztof Daniel 2013-02-27 08:21:10 EST
I think we are done with this work as described
http://eclipseandlinux.blogspot.com/2013/02/a-big-change-in-eclipse-p2.html.

Further problems should be reported against bundles that don't resolve.

Note You need to log in before you can comment on or make changes to this bug.