Bug 78617 - Segfault in netstat -p , after prolonged uptime (?)
Segfault in netstat -p , after prolonged uptime (?)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-26 10:50 EST by Need Real Name
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 08:48:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-26 10:50:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
Iv experienced issues on a bunch of systems that have prolonged uptime, when 
using the netstat -p flag -- that cause netstat to segfault.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. prolonged uptime
2. netstat -p
	

Actual Results:  [root@queenpin root]# netstat -p
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       
PID/Program name
tcp        0      0 queenpin.xfernet.n:pop3 co-briar-u1-c5a-15:4245 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:smtp mail.maclaunch.co:58925 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:pop3 host42.204.17.65.c:2572 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 202.163.65.3:41622      ESTABLISHED 
8869/httpd
tcp        0      0 queenpin.xfernet.n:pop3 65.162.41.194:5070      
ESTABLISHED -
tcp        0      0 queenpin.xfernet.:38294 queenpin.xfernet.n:smtp 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:51285       
FIN_WAIT2   -
tcp        0      0 queenpin.xfernet.n:pop3 65.162.41.194:6154      
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:50455       
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.:45593 xmlrpc.rhn.redhat:https ESTABLISHED 
30647/python
tcp        0      0 queenpin.xfernet.n:pop3 66-17-17-162.sktn.:1058 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:pop3 206.111.58.34:4759      
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:pop3 65.162.41.194:5652      
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:smtp mx1.officegarden.c:1287 
TIME_WAIT   -
tcp        0   9648 queenpin.xfernet.n:http xs195-241-204-224.:1153 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http wsproxy.icl.co.uk:10802 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http qn-213-73-174-156:42535 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:smtp sun-pdt-3.oregont:47420 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:smtp mail.cmbcomponents:3933 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http j3173.inktomisear:49651 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:pop3 c-24-126-232-187.w:4796 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:smtp AC98A5A8.ipt.aol.c:4281 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http wsproxy.icl.co.uk:10308 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http hooymeijer.nl:65309     
FIN_WAIT2   -
tcp        0      0 queenpin.xfernet.n:http j3189.inktomisearc:4024 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:pop3 ca-stmnca-cuda1-bl:2759 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:pop3 c-24-98-174-218.at:4336 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:50547       
TIME_WAIT  -
tcp        0      0 queenpin.xfernet.n:pop3 65.162.41.194:8554      
TIME_WAIT   -
tcp        0     21 queenpin.xfernet.n:pop3 65.162.41.194:5608      
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:smtp mail.western-insu:29307 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http ppp-80-246-194-78.:3646 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.ne:ssh modemcable086.245-:1069 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:smtp hitechparts1.erai.:4007 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http ppp-80-246-194-78.:3647 
TIME_WAIT   -
tcp        0   4065 queenpin.xfernet.n:pop3 64-51-232-243.cli:39634 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http ppp-80-246-194-78.:3647 
TIME_WAIT   -
tcp        0   4065 queenpin.xfernet.n:pop3 64-51-232-243.cli:39634 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:pop3 206.111.58.34:4081      
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http hooymeijer.nl:65421     
FIN_WAIT2   -
tcp        0      0 queenpin.xfernet.n:http ppp-80-246-194-78.:3645 
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http c66.191.66.93.dul.:1576 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http c66.191.66.93.dul.:1578 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http c66.191.66.93.dul.:1579 
ESTABLISHED -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:50597       
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:50596       
TIME_WAIT   -
tcp        0      0 queenpin.xfernet.n:http 62.108.68.1:51303       
FIN_WAIT2   -
tcp        0      0 queenpin.xfernet.n:pop3 ool-182c03fd.dyn.o:1186 
ESTABLISHED -
Active UNIX domain sockets (w/o servers)
Proto RefCnt Flags       Type       State         I-Node PID/Program name    
Path
unix  2      [ ]         DGRAM                    935961905 1778/bandwidth_mana 
@bandwidth
unix  17     [ ]         DGRAM                    935961903 
10103/syslogd       /dev/log
Segmentation fault


Expected Results:  exit state 0, rather got SIGSEGV

Additional info:

Iv experienced issues on a bunch of systems that have prolonged uptime, when 
using the netstat -p flag -- that cause netstat to segfault. I noticed this 
issue cause a service monitor i wrote greps netstat output for paticular prog. 
names and username. And it failed to properly run on many systems meeting the 
above scenario.
 
Majority of systems iv experienced this problem on are to the likes, of the 
below specifications:
RedHat 7.2 system, ide hd (40gb), 512mb ram
 
This system the issue is on at the moment has 78 days uptime, and is running 
the 2.4.18-17.7.x kernel, However iv run into this problem on my home rh 7.3 
system as well and i was asking around tonight and a few people noted similar 
issues on there rh boxes.
 
Reboot usualy corrects this but i wanted to bring light to this matter incase 
its an actual bug in netstat or the likes. Im not very skilled with C or gdb 
much but i hope the below shows ample information. Im leaving the box online 
incase you want further debugging.
 
Note: i was and still am unsure who this matter should be addressed to, so i do 
apoligize if i inconvinced anyone.
 
gdb --args netstat -p
(gdb) run
Starting program: /bin/netstat -p
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       
PID/Program name 
tcp        0      0 queenpin.xfernet.n:http cr003r01.sac2.fast:4101 
TIME_WAIT   -
......
......
...... 
Program received signal SIGSEGV, Segmentation fault.
0x08049828 in strcpy () at strcpy:-1
-1      strcpy: No such file or directory.
        in strcpy
(gdb) bt
#0  0x08049828 in strcpy () at strcpy:-1
#1  0x00000001 in ?? ()
#2  0x0804bf91 in strcpy () at strcpy:-1
#3  0x0804c12f in strcpy () at strcpy:-1
#4  0x0804d34c in strcpy () at strcpy:-1
#5  0x00149657 in __libc_start_main (main=0x804cc7c <strcpy+13856>, argc=2,
    ubp_av=0xbffffb84, init=0x8049104 <abuf.0+131467492>,
    fini=0x8055b40 <__umoddi3+496>, rtld_fini=0x11dcd4 <_dl_fini>,
    stack_end=0xbffffb7c) at ../sysdeps/generic/libc-start.c:129
Comment 1 Phil Knirsch 2003-02-11 08:54:20 EST
Hm, i tried to reproduce this but didn't manage on a 7.3 or a current release.
So if you could give it another shot on the current release i'd greately
appreciate it.

Thanks,

Read ya, Phil
Comment 2 Phil Knirsch 2003-08-19 08:48:34 EDT
Closing bug as worksforme.

Read ya, Phil
Comment 3 Adam Spiers 2003-12-05 12:04:47 EST
This is surely a duplicate of 77844.

Note You need to log in before you can comment on or make changes to this bug.