Bug 786513 - Rebase python-nose to 1.1.2
Rebase python-nose to 1.1.2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-nose (Show other bugs)
6.4
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Python Maintainers
BaseOS QE - Apps
: Rebase
Depends On:
Blocks: 782252
  Show dependency treegraph
 
Reported: 2012-02-01 11:30 EST by Richard W.M. Jones
Modified: 2016-07-13 11:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-13 11:53:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to python-nose.spec (2.00 KB, patch)
2012-02-01 11:30 EST, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2012-02-01 11:30:07 EST
Created attachment 558870 [details]
patch to python-nose.spec

See this page for the background:
https://home.corp.redhat.com/wiki/OpenStack

Current upstream python-nose is 1.1.2 (the website claims 1.1.3, but
I cannot find an actual download for that version).  The version in
RHEL 6 is 0.10.4 and hasn't been updated since 2008.  For OpenStack
testing we'd like a more recent version.

I checked the changelog file in the upstream sources, and there
are a considerable number of changes.  Most of them are bug fixes
but there are significant new features too.  It is unclear if
the new version of nose would require changes in other python
packages.  No package Requires python-nose, but it could be used
as a BuildRequire for a package (how to check?)

The change to the spec file to support the new version is minimal,
see attachment.
Comment 2 Richard W.M. Jones 2012-02-01 11:37:46 EST
These packages appear to BR python-nose:

TurboGears2-0:2.0.3-4.el6.src
numpy-0:1.3.0-6.2.el6.src
python-decorator-0:3.0.1-3.1.el6.src
python-formencode-0:1.2.2-2.1.el6.src
python-mako-0:0.3.4-1.el6.src
python-peak-util-assembler-0:0.5.1-1.el6.src
python-peak-util-symbols-0:1.0-4.1.el6.src
python-pylons-0:0.9.7-2.el6.src
python-repoze-what-0:1.0.8-6.el6.src
python-repoze-what-plugins-sql-0:1.0-0.6.rc1.el6.src
python-repoze-what-quickstart-0:1.0.1-1.el6.src
python-repoze-who-friendlyform-0:1.0-0.3.b3.el6.src
python-repoze-who-plugins-sa-0:1.0-0.4.rc1.el6.src
python-routes-0:1.10.3-2.el6.src
python-simplejson-0:2.0.9-3.1.el6.src
python-sqlalchemy-0:0.5.5-2.1.el6.src
python-tempita-0:0.4-2.el6.src
python-turbojson-0:1.2.1-8.1.el6.src
python-weberror-0:0.10.2-1.el6.src
python-webflash-0:0.1-0.2.a9.el6.src
python-webhelpers-0:0.6.4-4.el6.src
python-webob-0:0.9.6.1-3.el6.src
python-webtest-0:1.2-2.el6.src
yum-0:3.2.29-22.el6.src
python-elixir-0:0.6.1-5.el6.src
python-paver-0:1.0-4.el6.src
python-sphinx-0:0.6.6-2.el6.src
Comment 3 Richard W.M. Jones 2012-02-01 12:44:48 EST
I rebuilt all of the packages above in RHEL 6.3 using
python-nose 1.1.2.  Errors only are noted below.

python-repoze-what-quickstart
  Could not be rebuilt because of missing deps:
	python-repoze-who-plugins-sa is needed by python-repoze-what-quickstart-1.0.1-1.el6.noarch
	python-repoze-what-plugins-sql is needed by python-repoze-what-quickstart-1.0.1-1.el6.noarch

TurboGears2
  Could not be rebuilt because of missing deps:
	python-tw-forms is needed by TurboGears2-2.0.3-4.el6.noarch
	python-repoze-what-quickstart is needed by TurboGears2-2.0.3-4.el6.noarch

python-pylons
  Multiple test suite errors

python-simplejson
  Multiple test suite errors, but they all appeared to be because of this:
AttributeError: 'module' object has no attribute 'decoder'

python-webob:
  Multiple test suite errors of two kinds:
    NameError: name 'res2' is not defined
    OSError: [Errno 2] No such file or directory: '/usr/lib/python2.6/site-packages/docs/test-file.txt'
Comment 4 Suzanne Yeghiayan 2012-02-06 14:58:48 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 5 RHEL Product and Program Management 2012-07-10 04:39:52 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:58:46 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Orion Poplawski 2013-04-23 12:10:55 EDT
python-iptables, needed for StarCluster, requires nose >= 1.0.  Would be nice to see this updated.
Comment 8 RHEL Product and Program Management 2013-10-13 20:48:41 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.