Bug 786643 - [abrt] libreoffice-writer-3.3.4.1-2.fc15: BaseReference::iquery killed by signal 11 (SIGSEGV)
[abrt] libreoffice-writer-3.3.4.1-2.fc15: BaseReference::iquery killed by sig...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:b0094ab65ebbdb6206ca66d5377...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 20:55 EST by nomnex
Modified: 2012-03-01 09:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 09:14:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (26.26 KB, text/plain)
2012-02-01 20:56 EST, nomnex
no flags Details
File: maps (55.99 KB, text/plain)
2012-02-01 20:56 EST, nomnex
no flags Details
File: backtrace (44.65 KB, text/plain)
2012-02-01 20:56 EST, nomnex
no flags Details

  None (edit)
Description nomnex 2012-02-01 20:55:55 EST
abrt version: 2.0.3
architecture:   i686
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/swriter.bin -writer file:///home/mt/desktop/letter-merged-single-document.odt
component:      libreoffice
crash_function: com::sun::star::uno::BaseReference::iquery(com::sun::star::uno::XInterface*, com::sun::star::uno::Type const&)
executable:     /usr/lib/libreoffice/program/swriter.bin
kernel:         2.6.41.10-3.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-writer-3.3.4.1-2.fc15
reason:         Process /usr/lib/libreoffice/program/swriter.bin was killed by signal 11 (SIGSEGV)
time:           Thu Feb  2 10:24:34 2012
uid:            500
username:       mt

backtrace:      Text file, 45720 bytes
dso_list:       Text file, 26887 bytes
maps:           Text file, 57329 bytes

comment:
:- LO 3.3.4 on Fedora 15 LXDE.
:- Writer, Manual mail merge (I do not use the wizard).
:- Database is a spreadsheet.
:
:A crash occures randomely when I select "save as single document" at the end of the mail merge process
:
:In the Mail Merge window
:a. Records (All)
:b. Output > File > Save merged document >Save as single document
:
:At this stage, Writer terminates (crash) and a ABRT report is generated. It happened twice,
:with 2 newly created document.

environ:
:SSH_AGENT_PID=1219
:XDG_SESSION_ID=1
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=nh28d
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=pcmanfm-1237-nh28d-libreoffice-5_TIME5171289
:XDG_SESSION_COOKIE=c1c8ee9f2e790e7a86c758f000000017-1328135563.380768-1375315785
:HISTSIZE=1000
:OLDPWD=/usr/lib/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-ogOY0c
:IMSETTINGS_MODULE=IBus
:USER=mt
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386
:SSH_AUTH_SOCK=/tmp/ssh-KyPRkr1121/agent.1121
:DESKTOP_SESSION=LXDE
:PATH=/usr/lib/libfm:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/mt/bin
:MAIL=/var/spool/mail/mt
:QT_IM_MODULE=ibus
:PWD=/home/mt
:XMODIFIERS=@im=ibus
:EDITOR=nano
:GNOME_KEYRING_PID=1051
:LANG=en_US.UTF-8
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:_LXSESSION_PID=1121
:HOME=/home/mt
:SHLVL=2
:XDG_CONFIG_HOME=/home/mt/.config
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=mt
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-2pehLzlq5c,guid=ab7396438024e5e7f1dca63d000000c1
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:XDG_RUNTIME_DIR=/run/user/mt
:DISPLAY=:0.0
:GTK_IM_MODULE=ibus
:XDG_CURRENT_DESKTOP=LXDE
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/home/mt/.Xauthority
:_=/usr/lib/libreoffice/program/swriter.bin

var_log_messages:
:Feb  2 10:24:34 nh28d kernel: [10503.340673] swriter.bin[6163]: segfault at 0 ip 48aaac5b sp bfdb6c40 error 4 in libsfxli.so[488f5000+4b4000]
:Feb  2 10:24:37 nh28d abrt[7749]: saved core dump of pid 6163 (/usr/lib/libreoffice/program/swriter.bin) to /var/spool/abrt/ccpp-2012-02-02-10:24:34-6163.new/coredump (124747776 bytes)
Comment 1 nomnex 2012-02-01 20:56:00 EST
Created attachment 558945 [details]
File: dso_list
Comment 2 nomnex 2012-02-01 20:56:04 EST
Created attachment 558946 [details]
File: maps
Comment 3 nomnex 2012-02-01 20:56:06 EST
Created attachment 558947 [details]
File: backtrace
Comment 4 nomnex 2012-02-02 23:25:17 EST
follow up: I can't reproduce the crash merging other test documents.
Comment 5 Caolan McNamara 2012-02-28 11:23:24 EST
Is this still reproducible (sorry, slipped between the cracks), and if so can you give a step-by-step howto to get it to happen ?
Comment 6 nomnex 2012-03-01 09:07:24 EST
Hi Caolan, I have tried 2 times with a new document, so far so good. No crash. You  might want to close this bug. Thanks for your time.
Comment 7 Caolan McNamara 2012-03-01 09:14:29 EST
alright, sorry for letting this drop, but at least it seems to be "gone away"

Note You need to log in before you can comment on or make changes to this bug.