Bug 787627 - Brick with 0.1.1.1 ip address is considered as localhost
Brick with 0.1.1.1 ip address is considered as localhost
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: vpshastry
:
: 862494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-06 06:10 EST by shylesh
Modified: 2014-08-11 19:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: glusterfs-3.4.0qa5
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-02-06 06:10:25 EST
Description of problem:
Able to create a volume with the brick 0.1.1.1 as brick ip

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
often

Steps to Reproduce:
1.create a volume with the bricks 0.1.1.1:/brick1


  
Actual results:
Volume creation succeeds

Expected results:
should not succeed

Additional info:
Comment 1 vpshastry 2012-10-15 03:36:03 EDT
Change is merged in master, http://review.gluster.org/#change,3865.
Comment 2 Vijay Bellur 2012-10-25 03:22:16 EDT
*** Bug 862494 has been marked as a duplicate of this bug. ***
Comment 3 shylesh 2012-12-28 05:59:47 EST
Verified in build 3.4.0qa5-1.el6rhs.x86_64

Note You need to log in before you can comment on or make changes to this bug.