Bug 78793 - Conflicts + Provides => impossible to install a package?
Conflicts + Provides => impossible to install a package?
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
http://rpm.nogin.org/MetaPRL/rh80/htm...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-30 00:30 EST by Aleksey Nogin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-01 23:35:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2002-11-30 00:30:39 EST
rpm seems to be unwilling to install a package, thinking it conflicts itself!
This used to work in earlier versions of Red Hat.

# rpm -Uvh htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
error: Failed dependencies:
        htmldoc conflicts with htmldoc-nogui-1.8.23-1.rh8.0
# rpm -q htmldoc
package htmldoc is not installed
# rpm -q --whatprovides htmldoc
no package provides htmldoc
# rpm -q --provides -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
htmldoc
htmldoc-nogui = 1.8.23-1.rh8.0
# rpm -q --conflicts -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
htmldoc
# rpm -q rpm
rpm-4.1-1.06

The package I am trying to install can be d/l'ed at
http://rpm.nogin.org/MetaPRL/rh80/htmldoc-nogui-1.8.23-1.rh8.0.i386.html

P.S. rpm --rebuilddb does not help.
Comment 1 Jeff Johnson 2002-11-30 12:52:00 EST
Your conflicts is mis-written, expressing
	Conflict with all versions of htmldoc.
Comment 2 Aleksey Nogin 2002-12-01 23:35:29 EST
Exactly, htmldoc-nogui conflicts with any version of htmldoc. But htmldoc-nogui
is *not* htmldoc, it just provides it. 

Again, this used to work before.
Comment 3 Jeff Johnson 2002-12-02 09:59:23 EST
Again, you have a Provides: in htmldoc-nogui

# rpm -q --provides -p htmldoc-nogui-1.8.23-1.rh8.0.i386.rpm
 htmldoc
...

that is triggering the conflict. Don't do that.
Comment 4 Aleksey Nogin 2002-12-02 10:54:27 EST
OK, how then do I create a package htmldoc-nogui that has the following properties:

1) Any package that requires htmldoc, should install happily when htmldoc-nogui
is installed.
2) htmldoc-nogui conflicts htmldoc.

Note: this used to be possible with previous versions of RPM!

I could remove the Conflicts from the spec and rely on file conflicts, but that
just does not seem right...

Note You need to log in before you can comment on or make changes to this bug.