Bug 787962 - Anaconda screenshots are not saved after reboot
Summary: Anaconda screenshots are not saved after reboot
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-07 06:12 UTC by Wayne Pollock
Modified: 2013-02-14 02:49 UTC (History)
7 users (show)

Fixed In Version: anaconda-18.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-14 02:49:26 UTC


Attachments (Terms of Use)
copy of install ks file (1.74 KB, text/plain)
2012-02-07 17:28 UTC, Wayne Pollock
no flags Details

Description Wayne Pollock 2012-02-07 06:12:20 UTC
Description of problem:
Taking screenshots during Anaconda install seems to work, but the screenshots aren't saved.  I believe this is due to Anaconda saving them as documented, but in ~root on the RAM disk used for the installation.  Saved images should be copied to the new ~root once the root file system is formatted, but aren't.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Hit shift+ PrintScreen during (for example) partitioning screen.
2.
3.
  
Actual results:

Says the screenshot is saved.
It isn't there after reboot.

Expected results:
Should be there.

Additional info:

Documented in the Fedora 16 Installation guide:
9.2.1. Screenshots during installation
Anaconda allows you to take screenshots during the installation process. At any time during installation, press Shift+Print Screen and anaconda will save a screenshot to /root/anaconda-screenshots.

(I did notice the KickStart option for this explicitly states the screenshots get copied.  Haven't tried a KickStart install of F16 yet, so I don't know if that also has this problem.)

Comment 1 Chris Lumens 2012-02-07 15:20:02 UTC
Screenshots get copied into /root/anaconda-screenshots on the installed system when you hit the congratulations screen at the end of installation.  Did you see this screen?

Comment 2 Wayne Pollock 2012-02-07 17:28:06 UTC
Created attachment 560018 [details]
copy of install ks file

Comment 3 Chris Lumens 2012-02-08 18:26:17 UTC
You didn't really answer my question in comment #1.  Also, the kickstart option only applies if you use it.  I don't see any "autostep --autoscreenshot" command in your kickstart file.

Comment 4 Wayne Pollock 2012-02-08 21:41:54 UTC
Yes, I saw that screen.  I rebooted, agreed to the license and did all the firstboot stuff.  Then I logged in, did an "su" command, did a "cd" command, and
then did "ls".  There is no such folder there.

I know I didn't use kickstart, so autostep --autoscreenshot was not an option.  But I hopped that by seeing the KS file, you could tell exactly what I did.

In particular, I tried the screen-shot from the disk layout screen, before hitting "next" and saving the layout to disk.  Since the disk was formatted after taking the screenshot, I assume it is stored on the RAM disk, and then at the end, copied to /root.  I did see the install logs (and the ks file I attached) there, but no screen-shot directory.  When taking the screen-shot, I did get the pop-up dialog saying it was saved.  But it isn't there.

Twice (using VMs) I installed using the network install image, and once (no VM) using the installer DVD (not the live DVD).

Are you saying screenshots made that early, using manual install, works for you?

If you want, I could try again using a fresh VM, and record the screen during the install and afterward.  (But it would be a very large file, and a boring movie.)

Comment 5 Najam-us-Saqib 2012-02-17 06:58:55 UTC
I also have the same probleum with the screenshots of fedora16 installation. Please help me if someone get the solution.

Only some of the Screenshots were saved that are of the installation of packedges when you complete with the partition table. 

Thanks in advance.

Comment 6 AMM 2012-03-23 08:04:55 UTC
Same problem. No folder called /root/anaconda-screenshots exists after reboot to newly installed system.

I found folder called /tmp/anaconda-screenshots but it did not contain all the screenshots. Just 2 out of 8 were there.

Definitely some bug out there.

Comment 7 AMM 2012-03-23 08:07:24 UTC
Also as Najam-us-Saqib said, two snapshots that existed in /tmp were of package installation screen (when packages are installed)

Snapshots taken before and after are lost.

Comment 8 AMM 2012-03-25 06:14:40 UTC
I did more study.

1) Before partitions are made, anaconda copies screenshots to
/tmp/anaconda-screenshots/ of installer.
2) After partitions are made (and installation starts) it starts
copying to /mnt/sysimage/tmp/anaconda-screenshots/
3) After installation is over it switches back to /tmp/anaconda-screenshots/

And in the end, it *does not* copy anything to /mnt/sysimage/root/anaconda-screenshots.

So if you want snapshots, then before *rebooting* you should run
(manually by switching to console Alt-F2)

mkdir /mnt/sysimage/root/anaconda-screeenshots
cp /tmp/anaconda-screenshots/* /mnt/sysimage/tmp/anaconda-screenshots/* /mnt/sysimage/root/anaconda-screenshots/*

Hope this helps.

Comment 9 Chris Lumens 2012-08-03 19:36:55 UTC
I believe this should be fixed in F18 Alpha.  Please test and let us know.

Comment 10 Fedora End Of Life 2013-01-17 01:32:53 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 11 Fedora End Of Life 2013-02-14 02:49:31 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.