Bug 788045 - soffice --help wouldn't display help when soffice already running
Summary: soffice --help wouldn't display help when soffice already running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-07 10:39 UTC by Tomas Pelka
Modified: 2012-06-20 12:53 UTC (History)
1 user (show)

Fixed In Version: libreoffice-3.4.5.2-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: new faster startup helper not aware of the command line help option Consequence: activating the help feature from the command line when an instance is already executing doesn't work Fix: extend the startup scripts to handle the help feature under all circumstances Result: activating help from the command line works under all circumstances
Clone Of:
Environment:
Last Closed: 2012-06-20 12:53:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0798 normal SHIPPED_LIVE new packages: libreoffice 2012-06-19 21:00:52 UTC

Description Tomas Pelka 2012-02-07 10:39:52 UTC
Description of problem:
soffice --help wouldn't display help when soffice already running

Version-Release number of selected component (if applicable):
libreoffice-*-3.4.5.2-1.el6

How reproducible:
100%

Steps to Reproduce:
1. run soffice
2. run soffice --help again when soffice already running 
3.
  
Actual results:
no output

Expected results:
should display help

Additional info:

Comment 1 Caolan McNamara 2012-02-07 12:01:59 UTC
known fix upstream, will backport it

Comment 7 Caolan McNamara 2012-02-29 11:13:19 UTC
bah the *exact* original case of soffice --help should work, but any of the swriter, simpress etc wrappers add another agument to the command line and the original test to show help only works for 1 argument.

Comment 10 Caolan McNamara 2012-05-01 10:01:53 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: new faster startup helper not aware of the command line help option

Consequence: activating the help feature from the command line when an instance is already executing doesn't work

Fix: extend the startup scripts to handle the help feature under all circumstances

Result: activating help from the command line works under all circumstances

Comment 12 errata-xmlrpc 2012-06-20 12:53:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html


Note You need to log in before you can comment on or make changes to this bug.