Bug 788545 - GtkTreeModel.iter_previous and iter_next have confusingly different behaviour
GtkTreeModel.iter_previous and iter_next have confusingly different behaviour
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygobject3 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John (J5) Palmieri
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-08 07:17 EST by Vratislav Podzimek
Modified: 2013-03-13 00:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-20 06:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vratislav Podzimek 2012-02-08 07:17:05 EST
Description of problem:
While GtkTreeModel.iter_next(itr) has an override and does not modify itr, iter_previous(itr) modifies it. Since both these functions behave in the same way in the original C code I would expect this also in the Python gi binding.

Version-Release number of selected component (if applicable):
pygobject3-3.0.3-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. try to use iter_next(itr) and iter_previous(itr) from Python and see what's happening to itr
  
Actual results:
confusing difference in behaviour

Expected results:
no confusing difference -- preserving itr in both cases would be better
Comment 1 Vratislav Podzimek 2012-10-20 06:40:10 EDT
This is fixed in recent rawhide versions.

Note You need to log in before you can comment on or make changes to this bug.