Bug 789090 - spice-client: smart-card (CAC) support from the controller
spice-client: smart-card (CAC) support from the controller
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.3
Assigned To: Daniel Berrange
Virtualization Bugs
: FutureFeature
Depends On:
Blocks: 802736 892468
  Show dependency treegraph
 
Reported: 2012-02-09 14:13 EST by David Jaša
Modified: 2013-01-07 03:52 EST (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-1.el6
Doc Type: Enhancement
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: 696075
Environment:
Last Closed: 2012-06-20 08:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice-xpi test page (11.90 KB, text/html)
2012-03-16 05:24 EDT, David Jaša
no flags Details

  None (edit)
Comment 2 Marc-Andre Lureau 2012-03-01 10:55:58 EST
bug fixed in virt-viewer upstream, should be part of upcoming 0.5.2 release
Comment 6 Geyang Kong 2012-03-12 04:10:47 EDT
I cannot get enough information from comments in this bug and not sure how
to test this bug.I have also checked Bug 696075, but still have no idea how to test it. I need more informations such as what ENV I need to prepare and detailed steps I need to follow.
Comment 7 Geyang Kong 2012-03-12 05:13:23 EDT
Since we don't have env. to test this bug, do you still have env. can help us on this?
Comment 8 David Jaša 2012-03-12 12:56:06 EDT
Hi Geyang,

in order to verify the bug, you'll have to use the spice-xpi test page that does not feature smartcard toggle yet. I'll update the page later this week so you can wait with this (and I'll keep the needinfo on me set).

I'll post the (link to the) page when it will be ready.
Comment 9 David Jaša 2012-03-16 05:24:40 EDT
Created attachment 570543 [details]
spice-xpi test page

Geyang, this is the promised test page. It's pretty much self-explaining - when Smartcard is enabled and set, the client should work similarly like when you provide --spice-smartcard CLI option, when it is not set or disabled completely, it should not engage smartcard.
Comment 10 David Jaša 2012-03-16 11:39:26 EDT
verified in spice-client-0.8.2-13.el6.x86_64
Comment 11 David Jaša 2012-03-16 11:40:33 EDT
taking back, wrong component :(

For virt QE: the in virt-viewer, the feature worked for me too.
Comment 12 yuping zhang 2012-03-19 07:25:44 EDT
According comment 11,change the bug to VERIFIED.

Hi David,
Thanks very much for sending spice-xpi test page to us and testing this bug.We are trying smart card + spice now,hope we can test it in future. :)
Comment 13 David Jaša 2012-03-19 07:37:32 EDT
(In reply to comment #12)
> We
> are trying smart card + spice now,hope we can test it in future. :)

Hi Yuping,

The test page got merged to upstream spice-xpi git (at http://cgit.freedesktop.org/spice/spice-xpi) so you can take it from there. I guess that it will make it to downstream RHEL spice-xpi pretty fast, too.
Comment 14 yuping zhang 2012-03-19 07:45:58 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > We
> > are trying smart card + spice now,hope we can test it in future. :)
> 
> Hi Yuping,
> 
> The test page got merged to upstream spice-xpi git (at
> http://cgit.freedesktop.org/spice/spice-xpi) so you can take it from there. I
> guess that it will make it to downstream RHEL spice-xpi pretty fast, too.

OK.We will try it.Thank you.
Comment 15 Daniel Berrange 2012-04-17 07:34:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 17 errata-xmlrpc 2012-06-20 08:11:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.