Bug 789233 - cannot login system with minimal packages
cannot login system with minimal packages
Status: CLOSED DUPLICATE of bug 788829
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Alpha/F17AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-02-10 01:43 EST by Hongqing Yang
Modified: 2012-02-13 00:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 00:55:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
secure (1.59 KB, text/plain)
2012-02-10 01:43 EST, Hongqing Yang
no flags Details
install log (9.73 KB, text/plain)
2012-02-10 01:43 EST, Hongqing Yang
no flags Details
install log syslog (3.76 KB, text/plain)
2012-02-10 01:44 EST, Hongqing Yang
no flags Details
anaconda syslog (63.62 KB, text/plain)
2012-02-10 01:45 EST, Hongqing Yang
no flags Details
anaconda log (22.08 KB, text/plain)
2012-02-10 01:46 EST, Hongqing Yang
no flags Details
program log (50.11 KB, text/plain)
2012-02-10 01:47 EST, Hongqing Yang
no flags Details
storage log (127.28 KB, text/plain)
2012-02-10 01:48 EST, Hongqing Yang
no flags Details
druct log (87.88 KB, text/plain)
2012-02-10 01:49 EST, Hongqing Yang
no flags Details
audit log (50.37 KB, text/plain)
2012-02-10 01:49 EST, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-02-10 01:43:14 EST
Created attachment 560784 [details]
secure

Description of problem:

install with vnc, vnc conconnect or vnc password and minimal packages, after click reboot button on the vncviewer, the system does not reboot. 
by forcing power off and reboot the system, cannot login system with root.
boot system with init 1 and change the root password, still cannot login it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install with vnc
2. power off
3. boot system
  
Actual results:
cannot login

Expected results:
login normally

Additional info:
Comment 1 Hongqing Yang 2012-02-10 01:43:39 EST
Created attachment 560785 [details]
install log
Comment 2 Hongqing Yang 2012-02-10 01:44:35 EST
Created attachment 560786 [details]
install log syslog
Comment 3 Hongqing Yang 2012-02-10 01:45:55 EST
Created attachment 560787 [details]
anaconda syslog
Comment 4 Hongqing Yang 2012-02-10 01:46:23 EST
Created attachment 560788 [details]
anaconda log
Comment 5 Hongqing Yang 2012-02-10 01:47:31 EST
Created attachment 560789 [details]
program log
Comment 6 Hongqing Yang 2012-02-10 01:48:33 EST
Created attachment 560790 [details]
storage log
Comment 7 Hongqing Yang 2012-02-10 01:49:22 EST
Created attachment 560791 [details]
druct log
Comment 8 Hongqing Yang 2012-02-10 01:49:55 EST
Created attachment 560792 [details]
audit log
Comment 9 Hongqing Yang 2012-02-10 02:39:24 EST
reproduced with minimal packages installation
Comment 10 Hongqing Yang 2012-02-10 02:40:35 EST
set it as F17 Alpha Blocker according F17 Alpha Release Criteria article:
"When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles"
Comment 11 Tomas Mraz 2012-02-10 03:03:33 EST
This is not a regression in PAM as it did not change recently. Looking into the audit.log attached by you I see that the SELinux contexts are seriously messed up. I suppose it might be caused by the UsrMove change.
Comment 12 Hongqing Yang 2012-02-10 03:22:19 EST
(In reply to comment #11)
> This is not a regression in PAM as it did not change recently. Looking into the
> audit.log attached by you I see that the SELinux contexts are seriously messed
> up. I suppose it might be caused by the UsrMove change.

(In reply to comment #11)
> This is not a regression in PAM as it did not change recently. Looking into the
> audit.log attached by you I see that the SELinux contexts are seriously messed
> up. I suppose it might be caused by the UsrMove change.

yeah, after I set the selinux to permissive, it can be logged in.
Comment 13 Miroslav Grepl 2012-02-10 05:07:46 EST
Could you try to relabel your system

$ touch /.autorelabel;reboot

and see if this resolves your issue.
Comment 14 Miroslav Grepl 2012-02-10 07:33:10 EST
Ok, I got the same issue if I built my own live image. I am going to test it with the latest policy.
Comment 15 Miroslav Grepl 2012-02-10 07:57:23 EST
Looks like it happens also on update.
Comment 16 Daniel Walsh 2012-02-10 08:59:02 EST
If it is mislabeled then there is something going wrong in livecd builder.  In the last step of the livecd-tools it is supposed to fix all the labels, is this failing?  Do you see anything in the logs of livecd build?
Comment 17 Brian Lane 2012-02-10 11:19:28 EST
To be clear, is this a problem with the livecd booting or the system installed from livecd booting? Also, if you could test with the TC2 image so that everyone is on the same page that would be good. Self-built images could be pulling wrong packages, untested updates, etc. etc.
Comment 18 Adam Williamson 2012-02-10 12:18:41 EST
Could this be the same as my https://bugzilla.redhat.com/show_bug.cgi?id=788829 ? Same symptom - 'can't log in' - and apparently the same cause - 'SELinux contexts are seriously messed up'. I think we need to know what the hell keeps 'seriously messing up' the SELinux contexts.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2012-02-10 12:24:19 EST
Discussed at the 2012-02-10 blocker review meeting. Agreed we're concerned there's something wiggy going on with SELinux contexts in current Rawhide and this may well be related to 788829, but we'd like a clearer understanding of what's going on before we declare this to be a blocker. We'd also like to know what image Hongqing installed from - Hongqing, was this TC1? TC2? DVD? netinst?

We will revisit this bug at the 2012-02-17 blocker review meeting.
Comment 20 Andre Robatino 2012-02-10 12:31:36 EST
Hongqing was using TC2 as indicated by the TC1 and TC2 install test pages - the only references to this bug are on the TC2 page. I also saw this on TC2 but not TC1. (I got a working minimal install on one of the TC2 DVDs which showed this bug. I didn't get a working install with the other DVD. With TC1, I got working minimal installs from both DVDs and neither had this problem.)
Comment 21 Hongqing Yang 2012-02-13 00:55:00 EST
It should be the same with bug 788829. It also cannog be logged in with graphical mode.

*** This bug has been marked as a duplicate of bug 788829 ***

Note You need to log in before you can comment on or make changes to this bug.