Bug 789331 - Spice client crashed when connecting to a guest without spice-vdagent running
Spice client crashed when connecting to a guest without spice-vdagent running
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spice-client (Show other bugs)
5.8
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
: ZStream
Depends On:
Blocks: 790894
  Show dependency treegraph
 
Reported: 2012-02-10 08:06 EST by Marian Krcmarik
Modified: 2013-01-08 02:43 EST (History)
6 users (show)

See Also:
Fixed In Version: spice-client-0.8.1-8.el5
Doc Type: Bug Fix
Doc Text:
The SPICE client did not correctly handle an exception which was raised when trying to connect to a guest operating system with no running SPICE agent. Consequently, the SPICE client application terminated unexpectedly after the 30-second timeout. With this update, the SPICE client correctly handles this situation and successfully connects to the guest system without unnecessary waiting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:43:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-02-10 08:06:38 EST
Description of problem:
Spice client crashed when connecting to a guest without spice-agent running with unhandled exception:
main: unhandled exception: vdagent timeout
The crash occurs after 30' timeout when Client tries to connect with spice-agent, This prevents to connect to a guest machine without spice-vdagent running (for example during installation of guest or to RHEL5 guests since It does not have spice-vdagent).
This is most likely fixed on RHEL6 spice-client.

Version-Release number of selected component (if applicable):
spice-client-0.8.1-6

How reproducible:
Always

Steps to Reproduce:
1. Connect to a guest without spice-vdagent running through User portal of RHEVM

  
Actual results:
Spice client crashes with unhandled exception: vdagent timeout after 30'

Expected results:


Additional info:
Comment 3 Christophe Fergeau 2012-02-15 08:56:50 EST
Changes pushed to the rhel-5-9 branch
Comment 4 Christophe Fergeau 2012-02-15 09:56:34 EST
I got it built in brew https://brewweb.devel.redhat.com/taskinfo?taskID=4045608
Comment 6 Christophe Fergeau 2012-02-16 15:37:53 EST
Pushed a new version to get it built on i686 too.
Comment 7 Miroslav Svoboda 2012-02-21 07:08:09 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The SPICE client did not correctly handle an exception which was raised when trying to connect to a guest operating system with no running SPICE agent. Consequently, the SPICE client application terminated unexpectedly after the 30-second timeout. With this update, the SPICE client correctly handles this situation and successfully connects to the guest system without unnecessary waiting.
Comment 11 errata-xmlrpc 2013-01-08 02:43:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0096.html

Note You need to log in before you can comment on or make changes to this bug.