Bug 789404 - [abrt] virt-manager-0.9.1-1.fc16: __memmove_ssse3_back: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] virt-manager-0.9.1-1.fc16: __memmove_ssse3_back: Process /usr/bin/pyth...
Status: CLOSED DUPLICATE of bug 814122
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
abrt_hash:2f62e12b16cf7e9fb382ebc8ae8...
:
: 678901 708727 785651 790368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 12:25 EST by Ian Pilcher
Modified: 2012-06-17 17:25 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 17:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (17.20 KB, text/plain)
2012-02-10 12:25 EST, Ian Pilcher
no flags Details
File: maps (70.05 KB, text/plain)
2012-02-10 12:25 EST, Ian Pilcher
no flags Details
File: backtrace (182.68 KB, text/plain)
2012-02-10 12:25 EST, Ian Pilcher
no flags Details
File: backtrace (189.61 KB, text/plain)
2012-03-12 06:26 EDT, Florian Schmid
no flags Details
File: backtrace (181.25 KB, text/plain)
2012-03-30 13:32 EDT, adam
no flags Details

  None (edit)
Description Ian Pilcher 2012-02-10 12:25:08 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager.py
comment:        Running a Windows 7 VM with a full-screen SPICE display (1920x1200).  SPICE/virt-manager appeared to be hung and then crashed.
crash_function: __memmove_ssse3_back
executable:     /usr/bin/python
kernel:         3.2.3-2.fc16.x86_64
pid:            4499
pwd:            /home/ipilcher
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Fri 10 Feb 2012 11:08:16 AM CST
uid:            1000
username:       ipilcher

backtrace:      Text file, 187068 bytes
dso_list:       Text file, 17609 bytes
maps:           Text file, 71729 bytes

environ:
:XDG_VTNR=1
:KDE_MULTIHEAD=false
:SSH_AGENT_PID=2033
:XDG_SESSION_ID=1
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=localhost.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:DESKTOP_STARTUP_ID=localhost.localdomain;1328890044;405993;2161_TIME3057606
:TERM=dumb
:SHELL=/bin/bash
:XDG_MENU_PREFIX=kde4-
:XDM_MANAGED=method=classic
:XDG_SESSION_COOKIE=caff33944a9334bdaf03f9d700000016-1328887064.797524-175539664
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/ipilcher/.gtkrc-2.0:/home/ipilcher/.gtkrc-2.0-kde4:/home/ipilcher/.kde/share/config/gtkrc-2.0
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/ipilcher/.gtkrc:/home/ipilcher/.kde/share/config/gtkrc
:GS_LIB=
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=ipilcher
:SSH_AUTH_SOCK=/tmp/ssh-YDnHXohF1888/agent.1888
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2145,unix/unix:/tmp/.ICE-unix/2145
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/ipilcher/.local/bin:/home/ipilcher/bin
:DESKTOP_SESSION=default
:MAIL=/var/spool/mail/ipilcher
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:QT_IM_MODULE=xim
:PWD=/home/ipilcher
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:KDE_SESSION_UID=1000
:KDEDIRS=/usr
:HISTCONTROL=ignoredups
:HOME=/home/ipilcher
:XDG_SEAT=seat0
:SHLVL=2
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=default
:LOGNAME=ipilcher
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-hf0DCxeFSO,guid=f959bdc7c57adbdfbbfbbdeb0000004e
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/ipilcher
:QT_PLUGIN_PATH=/home/ipilcher/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/tmp/kde-ipilcher/xauth-1000-_0

var_log_messages:
:Feb  9 09:02:31 localhost yum[2516]: Updated: spice-gtk-python-0.9-1.fc16.x86_64
:Feb 10 11:08:16 localhost kernel: [ 6693.345725] python[4499]: segfault at 7f38c09216c0 ip 00007f38e1d67160 sp 00007fffdc3c34c8 error 4 in libc-2.14.90.so[7f38e1c22000+1ab000]
:Feb 10 11:08:20 localhost abrt[11205]: Saved core dump of pid 4499 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-02-10-11:08:16-4499 (323837952 bytes)
Comment 1 Ian Pilcher 2012-02-10 12:25:12 EST
Created attachment 560936 [details]
File: dso_list
Comment 2 Ian Pilcher 2012-02-10 12:25:14 EST
Created attachment 560937 [details]
File: maps
Comment 3 Ian Pilcher 2012-02-10 12:25:15 EST
Created attachment 560938 [details]
File: backtrace
Comment 4 Cole Robinson 2012-02-10 16:31:19 EST
Moving to spice-gtk
Comment 5 Cole Robinson 2012-02-14 07:08:33 EST
*** Bug 790368 has been marked as a duplicate of this bug. ***
Comment 6 Cole Robinson 2012-02-14 07:09:22 EST
*** Bug 785651 has been marked as a duplicate of this bug. ***
Comment 7 Florian Schmid 2012-03-12 06:26:06 EDT
Problem occurs regularly while working with different qemu domains.
First mouse input to graphical console doesn't work, then all virtual machine windows freeze.
However virtualization is still running in background and once virt-manager is automatically killed (or manually) work can be resumed.


backtrace_rating: 4
Package: virt-manager-0.9.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 8 Florian Schmid 2012-03-12 06:26:15 EDT
Created attachment 569352 [details]
File: backtrace
Comment 9 abrt-bot 2012-03-21 11:35:06 EDT
Backtrace analysis of bugs across components suggests the actual bug is in component cairo or libX11 instead of component spice-gtk, reassigning to cairo.

Bugs which were found to be similar to this bug: 
  evince: bug #678901, bug #708727
  spice-gtk: bug #785651
  virt-manager: bug #790368

This comment is automatically generated.
Comment 10 abrt-bot 2012-03-21 11:35:27 EDT
*** Bug 678901 has been marked as a duplicate of this bug. ***
Comment 11 abrt-bot 2012-03-21 11:35:40 EDT
*** Bug 708727 has been marked as a duplicate of this bug. ***
Comment 12 adam 2012-03-30 13:32:11 EDT
Virt Manager Console for VMs just freezes/crashes after some time

backtrace_rating: 4
Package: virt-manager-0.9.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 13 adam 2012-03-30 13:32:17 EDT
Created attachment 574045 [details]
File: backtrace
Comment 14 Marc-Andre Lureau 2012-03-30 20:40:15 EDT
That backtrace has been identified as a bug in spice-gtk, and a proposed fix has been submitted to the ML.

The next spice-gtk release should fix this bug.
Comment 15 Cole Robinson 2012-06-17 17:25:51 EDT

*** This bug has been marked as a duplicate of bug 814122 ***

Note You need to log in before you can comment on or make changes to this bug.