Bug 78999 - RFE: swap Control and CapsLock keys
RFE: swap Control and CapsLock keys
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-04 10:07 EST by Thomas Dodd
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-22 17:30:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Dodd 2002-12-04 10:07:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3a) Gecko/20021118

Description of problem:
Reposting the RFE from bug#74130
A check box for this option in rh-cfg-xf86 would be nice too.
Likewise one for emulate 3 buttons mice.
Having that option also switch the keys in console mode would be outstanding. If
a user does it in X they are likely to want it on the console too.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-xfree86
2.How to swap the control and caps keys?
3.

Actual Results:  Starting rh-cfg-xf should have an option to swap those key. It
was in Xconfigurator, XF86Setup, and xf86cfg. It's still in the XF86Config file,
but there's no UI to change it now.

If possible it should also incluse an option to do the same swap for the
console. I edit /lib/kbd/keymaps/i386/qwerty/us.map.gz to do it. There's
probably an easier way, that would work for other keyboard types too, but I
don't really understand the whole setup of /lib/kbd and loadkeys.


Additional info:
Comment 1 Brent Fox 2002-12-20 04:19:59 EST
This feature request belongs more to redhat-config-keyboard than
redhat-config-xfree86, so I changed components.

However, my opinion is that the vast majority of users do not want to swap the
ctrl and caps lock keys and those that do will know how to edit the XF86Config
file.  There are a jillion X keyboard options that you can set, but exposing
those in a UI is just not the right thing for most users.  

Resolving as 'wontfix'
Comment 2 Thomas Dodd 2002-12-20 09:59:52 EST
I would disagree. That option was in the XF86 config tools for a long time,
XF86Setup, and Xconfigurator. It is still added, as a comment to the XF86Config
file.

Most users from a unix background would do it if it was simple. That's why XF86
created the option, to mke the PC keyboard layout like the Unix layout. Every
Sparc I've ever used had the position swapped. I also know several people that
have swapped them in Windoze, using a horrid registry hack, because they expect
the position to be different.

This biggest is to swap them in both X and the console. Finding the correct
file, and swaping the keycodes for the console is not as simple as using the X
option. I have us-swap.map in /lib/kbd/keymaps/i386/qwerty/, but finding that
took a while, and it is on for a US qwerty keyboard. Someone who understands the
kmaps could probaly do it better, and make it work for all keyboards.

If you only want windoze users, tio use linux, then it's fine to remove. But if
you want the Unix world to switch, it's helpfull. A lot of the admins may not
know about it, especially the console swap. The four Sun/Solaris guys here don't
yet. Since they're talking about switching to linux for workstations, it would
be handy to keep around, and improve.

Has Mandrake or SuSe dropped it for X? I guess I should look.

Sun's new systems still ship with <Control> between >Tab> and <Shift>, including
the Blade and Linux boxes. So those users are used to it there.

And it much easier to use in that position. Copmare the common emacs, bash, and
tcsh <Ctrl>+<key> combinations with the different locations.
Comment 3 Mike A. Harris 2002-12-20 10:29:37 EST
This option doesn't sound unreasonable to me.  I don't use it, and never have
seen people who do, but after asking on a few IRC channels if anyone uses the
option I got back enough yes answers that it might be a good option to keep
around, although I'm personally impartial myself.

John, any thoughts?
Comment 4 Brent Fox 2002-12-22 17:30:20 EST
People have lots of requests for redhat-config-keyboard to configure the various
keyboard options in X, most of which don't make sense for the average user. 
Putting these options in the interface leads to clutter and confusion.  The fact
that the option has existed in previous config tools does not sway me because
none of those tools was even close to having a good user interface.

My main objection is that there's really no place for it in the GUI.  If I add
the option for swapping Ctrl and Caps Lock, then it gets harder for me to say no
to the guy who wants to swap the Alt and AltGr keys.  It just gets out of hand
really quickly.  I'd rather make a tool that is too simple for some people than
a tool that is too complex for most.  

I still believe that most of those who would like to swap Ctrl and Caps Lock are
capable of finding the option in the XF86Config file.  As you say, the option is
already there in the file but commented out.  I'd rather have the experienced
users do an extra step than have the newbies confused by the options that are
unrelated to selecting the keymap for the system.

Note You need to log in before you can comment on or make changes to this bug.