Bug 790233 - [abrt] libreoffice-writer-3.3.4.1-2.fc15: crash deleting styles from template dialog (SIGSEGV)
[abrt] libreoffice-writer-3.3.4.1-2.fc15: crash deleting styles from template...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:4e2cc0cfb82a7178b664db4c79e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-13 19:36 EST by nomnex
Modified: 2012-06-08 15:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 09:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (20.31 KB, text/plain)
2012-02-13 19:36 EST, nomnex
no flags Details
File: maps (44.73 KB, text/plain)
2012-02-13 19:36 EST, nomnex
no flags Details
File: backtrace (59.80 KB, text/plain)
2012-02-13 19:36 EST, nomnex
no flags Details
print-screen template management (38.83 KB, image/png)
2012-06-08 11:18 EDT, nomnex
no flags Details
Print-screen delete context menu (37.01 KB, image/png)
2012-06-08 12:01 EDT, nomnex
no flags Details

  None (edit)
Description nomnex 2012-02-13 19:36:04 EST
abrt version: 2.0.3
architecture:   i686
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/swriter.bin -writer
component:      libreoffice
crash_function: SwDocStyleSheet::PresetNameAndFamily
executable:     /usr/lib/libreoffice/program/swriter.bin
kernel:         2.6.42.3-2.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-writer-3.3.4.1-2.fc15
reason:         Process /usr/lib/libreoffice/program/swriter.bin was killed by signal 11 (SIGSEGV)
time:           Tue Feb 14 09:08:48 2012
uid:            500
username:       mt

backtrace:      Text file, 61239 bytes
dso_list:       Text file, 20795 bytes
maps:           Text file, 45802 bytes

comment:
:Deleting several styles, in Templates > Organize > Document (or) Template makes LibreOffice to crash.
:
:I can reproduce the crash (Always)
:
:Open a writer document or template
:Open the Organize Templates window
:Click on the document or template to show its styles
:Delete some styles one by one (only option)
:LibreOffice terminates after the second or third style deletion

environ:
:SSH_AGENT_PID=1306
:XDG_SESSION_ID=2
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=nh28d
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:SHELL=/bin/bash
:TERM=dumb
:XDG_SESSION_COOKIE=c1c8ee9f2e790e7a86c758f000000017-1329174098.423675-1123507701
:HISTSIZE=1000
:OLDPWD=/usr/lib/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-xiut8c
:IMSETTINGS_MODULE=IBus
:USER=mt
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386
:SSH_AUTH_SOCK=/tmp/ssh-hQazih1205/agent.1205
:DESKTOP_SESSION=LXDE
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/mt/bin
:MAIL=/var/spool/mail/mt
:QT_IM_MODULE=ibus
:PWD=/home/mt
:XMODIFIERS=@im=ibus
:EDITOR=nano
:GNOME_KEYRING_PID=1135
:LANG=en_US.UTF-8
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:_LXSESSION_PID=1205
:HOME=/home/mt
:SHLVL=2
:XDG_CONFIG_HOME=/home/mt/.config
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=mt
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-5sPBcDaRH7,guid=00e865f608ea7868d13e1ce2000000d6
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:XDG_RUNTIME_DIR=/run/user/mt
:DISPLAY=:0
:GTK_IM_MODULE=ibus
:XDG_CURRENT_DESKTOP=LXDE
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/home/mt/.Xauthority
:_=/usr/lib/libreoffice/program/swriter.bin

var_log_messages:
:Feb 14 08:56:36 nh28d kernel: [ 3510.820362] swriter.bin[2280]: segfault at 30000 ip 4b194fb6 sp bfa04e90 error 4 in libswli.so[4a8ff000+d51000]
:Feb 14 08:56:38 nh28d abrt[2579]: saved core dump of pid 2280 (/usr/lib/libreoffice/program/swriter.bin) to /var/spool/abrt/ccpp-2012-02-14-08:56:36-2280.new/coredump (103591936 bytes)
:Feb 14 09:08:48 nh28d kernel: [ 4243.330980] swriter.bin[2623]: segfault at 9 ip 4b194fb8 sp bfdd3350 error 4 in libswli.so[4a8ff000+d51000]
:Feb 14 09:08:50 nh28d abrt[2982]: saved core dump of pid 2623 (/usr/lib/libreoffice/program/swriter.bin) to /var/spool/abrt/ccpp-2012-02-14-09:08:48-2623.new/coredump (98844672 bytes)
Comment 1 nomnex 2012-02-13 19:36:10 EST
Created attachment 561713 [details]
File: dso_list
Comment 2 nomnex 2012-02-13 19:36:20 EST
Created attachment 561714 [details]
File: maps
Comment 3 nomnex 2012-02-13 19:36:29 EST
Created attachment 561715 [details]
File: backtrace
Comment 4 Caolan McNamara 2012-05-15 10:47:50 EDT
Backtrace shows that this is a crash removing a style via the template dialog, but I struggled to be able to delete *any* user-defined style from that dialog.

Turns out that being unable to delete styles from the dialog seems to have been accidentally disabled since around 2006. I've fixed that part of things upstream as http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdd4d969b1446ca0492adda239f5caf9987b84eb and now can delete styles from documents/templates again from organize->templates without any apparent problem.

I'm inclined to think that your crash is triggered by the problem I've fixed, but I'm a little unsure, because I don't understand how you were able to delete styles without the fix :-)
Comment 5 Caolan McNamara 2012-06-08 09:28:55 EDT
I'm going to assume this crash is somehow related to the busted logic in sfx2/source/doc/docvor.cxx which I've fixed upstream, in which case it'll be good in F18. Seeing as its not definite that it is I won't backport to a stable release
Comment 6 nomnex 2012-06-08 11:18:38 EDT
Created attachment 590460 [details]
print-screen template management

Just to make sure, the crash occurs when I delete the custom styles of a document using the template management.

I join a print-screen, see the red rectangle. NB: This document is an default document without custom styles. Assuming the document would have some custom styles, removing would reproduce this bug.

are we talking about the same issue?
Comment 7 Caolan McNamara 2012-06-08 11:30:37 EDT
yeah, that's the dialog I'm talking about. But I'm interested in *how* are you "removing" them, because the bug I fixed was that pressing delete wasn't doing anything, or right clicking a style wasn't showing the "delete" option because it was looking at the wrong index.
Comment 8 nomnex 2012-06-08 12:01:39 EDT
Created attachment 590465 [details]
Print-screen delete context menu

LibreOffice 3.3.4 
OOO330m19 (Build:401)
Ver: 3.3.4.1-4.fc15

There is a context menu Delet, and I confirm on the window "Are you sure you want to delete the style".

When I remove more than 1 single style in a row, writer crashes.

You last comment says you have removed access to the feature. That was (is ;)) very handy to remove some document custom styles this way. Any chance to re-gain the feature in a later LO version, minus the crashes?
Comment 9 nomnex 2012-06-08 12:03:12 EDT
Sorry, it's late here. It will be fixed in F-18, in your comment 5
Comment 10 Caolan McNamara 2012-06-08 15:38:47 EDT
Really odd that your F-15 screenshot has that while my F15+ doesn't and my fix was to fix the code that made it not appear. *shrug*, its *hopefully* all the same underlying problem.

Note You need to log in before you can comment on or make changes to this bug.