This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 790439 - agent rpm conf directory under /etc
agent rpm conf directory under /etc
Status: CLOSED ERRATA
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.3
Unspecified Unspecified
high Severity unspecified (vote)
: ---
: JON 3.1.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 707235
  Show dependency treegraph
 
Reported: 2012-02-14 09:44 EST by Aleksandar Kostadinov
Modified: 2013-09-05 12:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 12:23:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Kostadinov 2012-02-14 09:44:25 EST
Description of problem:
I think that in jon agent RPM
/usr/share/jboss-on-3.0.1.GA/agent/conf
should be a link to a directory in /etc because on RHEL most configuration files belong there.
Comment 1 Stefan Negrea 2012-04-24 09:15:50 EDT
There currently no support to change the location of the configuraiton folder, the agent expects it to be in a conf folder relative to the root of the agent files. Updated the RPM using the same symlink solution applied for logs folder. The configuration will be effectively stored in /etc, as per RHEL guidelines.

A /etc/jboss-on/agent folder is created during RPM installation to store
configuration files. A symlink /usr/share/jboss-on-${version}.GA/agent/conf pointing to /etc/jboss-on/agent is also created during installation.
Comment 3 Mike Foley 2013-09-05 12:23:43 EDT
JON RPM Agent is on the CP

Note You need to log in before you can comment on or make changes to this bug.