Bug 790894 - Spice client crashed when connecting to a guest without spice-vdagent running
Spice client crashed when connecting to a guest without spice-vdagent running
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: spice-client (Show other bugs)
5.8
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
: ZStream
Depends On: 789331
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 11:59 EST by Chris Pelland
Modified: 2012-02-21 07:08 EST (History)
9 users (show)

See Also:
Fixed In Version: spice-client-0.8.1-6.el5_8.2
Doc Type: Bug Fix
Doc Text:
The SPICE client did not correctly handle an exception which was raised when trying to connect to a guest operating system with no running SPICE agent. Consequently, the SPICE client application terminated unexpectedly after the 30-second timeout. With this update, the SPICE client correctly handles this situation and successfully connects to the guest system without unnecessary waiting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-02-15 11:59:52 EST
This bug has been copied from bug #789331 and has been proposed
to be backported to 5.8 z-stream (EUS).
Comment 5 Christophe Fergeau 2012-02-16 08:19:45 EST
I'll need to make another build, for some reason this build was only built for x86_64, trying to figure out what's going on.
Comment 6 Christophe Fergeau 2012-02-16 15:29:12 EST
New build pushed with i686 packages this time
Comment 7 Lubos Kocman 2012-02-20 13:23:15 EST
Verified on spice-client-0.8.1-6.el5_8.2 {i686,x86_64)
Comment 8 errata-xmlrpc 2012-02-21 00:02:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0147.html
Comment 9 Miroslav Svoboda 2012-02-21 07:08:07 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The SPICE client did not correctly handle an exception which was raised when trying to connect to a guest operating system with no running SPICE agent. Consequently, the SPICE client application terminated unexpectedly after the 30-second timeout. With this update, the SPICE client correctly handles this situation and successfully connects to the guest system without unnecessary waiting.

Note You need to log in before you can comment on or make changes to this bug.