Bug 791033 - FTBFS with OpenJDK7
FTBFS with OpenJDK7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: saxon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andy Grimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 19:26 EST by Omair Majid
Modified: 2016-11-07 22:46 EST (History)
4 users (show)

See Also:
Fixed In Version: saxon-9.3.0.4-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 15:48:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to set encoding in the build system (656 bytes, text/x-csrc)
2012-02-15 19:26 EST, Omair Majid
no flags Details

  None (edit)
Description Omair Majid 2012-02-15 19:26:11 EST
Created attachment 562357 [details]
patch to set encoding in the build system

Saxon fails to build from source with openjdk7. This is caused by not specifying the encoding of files that are not encoded in ASCII. The attached patch fixes this.

Please see https://fedoraproject.org/wiki/Java7_Package_Rebuild_Status for more information.
Comment 1 Andy Grimm 2012-02-15 21:00:48 EST
This is in progress. I'm also adding a POM file in the new build. Thanks for the patch.
Comment 2 Fedora Update System 2012-02-15 22:36:37 EST
saxon-9.3.0.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/saxon-9.3.0.4-3.fc17
Comment 3 Fedora Update System 2012-02-16 14:25:12 EST
Package saxon-9.3.0.4-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing saxon-9.3.0.4-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-1802/saxon-9.3.0.4-3.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-06 15:48:34 EST
saxon-9.3.0.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2012-07-11 12:48:24 EDT
saxon-9.3.0.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/saxon-9.3.0.4-4.fc17
Comment 6 Fedora Update System 2012-08-05 17:37:14 EDT
saxon-9.3.0.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.