Bug 791203 - [abrt] libpurple-2.7.9-3.el6.2: warnings.py:29:_show_warning:AttributeError: 'NoneType' object has no attribute 'write'
[abrt] libpurple-2.7.9-3.el6.2: warnings.py:29:_show_warning:AttributeError: ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pidgin (Show other bugs)
6.2
i686 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthias Clasen
Desktop QE
abrt_hash:9f5779815f9763722c9d852be20...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-16 08:44 EST by Alexander Todorov
Modified: 2017-12-06 06:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:13:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: sosreport.tar.xz (1.73 MB, text/plain)
2012-02-16 08:44 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2012-02-16 08:44:29 EST
abrt version: 2.0.5
cmdline:        
executable:     /usr/bin/purple-url-handler
kernel:         2.6.32-220.4.2.el6.i686
reason:         warnings.py:29:_show_warning:AttributeError: 'NoneType' object has no attribute 'write'
time:           16.02.2012 (чт) 15,27,10 EET
uid:            500
username:       atodorov

sosreport.tar.xz: Binary file, 1813436 bytes

backtrace:
:warnings.py:29:_show_warning:AttributeError: 'NoneType' object has no attribute 'write'
:
:Traceback (most recent call last):
:  File "/usr/bin/purple-url-handler", line 395, in <module>
:    main()
:  File "/usr/bin/purple-url-handler", line 391, in main
:    print "Error: %s" % (e.message)
:  File "/usr/lib/python2.6/warnings.py", line 29, in _show_warning
:    file.write(formatwarning(message, category, filename, lineno, line))
:AttributeError: 'NoneType' object has no attribute 'write'
:
:Local variables in innermost frame:
:category: <type 'exceptions.DeprecationWarning'>
:filename: '/usr/bin/purple-url-handler'
:lineno: 391
:file: None
:line: None
:message: DeprecationWarning('BaseException.message has been deprecated as of Python 2.6',)

comment:
:1) Opened http://www.bugzilla.org/support/
:2) Clicked on #bugzilla link (irc://irc.mozilla.org/bugzilla)
:3) Selected to open the link with purple-url-handler
Comment 1 Alexander Todorov 2012-02-16 08:44:42 EST
Created attachment 562497 [details]
File: sosreport.tar.xz
Comment 2 Suzanne Yeghiayan 2012-03-07 16:27:52 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 3 RHEL Product and Program Management 2012-07-10 04:30:36 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:54:55 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-09-07 01:35:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Jan Kurik 2017-12-06 06:13:41 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.