Bug 794675 - libtoolize depends on tar
Summary: libtoolize depends on tar
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-17 09:53 UTC by Arenas Belon, Carlo Marcelo
Modified: 2012-10-04 06:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-04 06:57:57 UTC


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2012-02-17 09:53:52 UTC
Description of problem:
# libtoolize --automake --copy
libtoolize: can not copy '/usr/share/libtool/config/ltmain.sh' to 'build/'

Version-Release number of selected component (if applicable):
2.4.2-3.fc17

How reproducible:
always

Steps to Reproduce:
1. install fedora with minimal profile
2. install libtool
3. run libtoolize
  
Actual results:
fail to run

Expected results:
no error, because installing libtool should pull tar as a dependency

Additional info:
problem solved by running

# yum install tar

there is a reference upstream in :

  http://osdir.com/ml/libtool-gnu/2009-07/msg00030.html

and it is likely to affect older versions as well as shown by the date of that post.

Comment 1 Pavel Raiskup 2012-10-04 06:57:57 UTC
Thanks for the report.  I added tar as a dependency for libtool in rawhide.

| --- a/libtool.spec
| +++ b/libtool.spec
| @@ -3,7 +3,7 @@
|  Summary: The GNU Portable Library Tool
|  Name:    libtool
|  Version: 2.4.2
| -Release: 7%{?dist}
| +Release: 8%{?dist}
|  License: GPLv2+ and LGPLv2+ and GFDL
|  URL:     http://www.gnu.org/software/libtool/
|  Group:   Development/Tools
| @@ -15,6 +15,8 @@ Requires(post):  /sbin/install-info
|  Requires(preun): /sbin/install-info
|
|  BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo
| +# we need this because tar is missing in Fedora installed with min. profile
| +BuildRequires: tar
|  Requires: autoconf >= 2.58, automake >= 1.4, sed
|  # make sure we can configure all supported langs
|  BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran, gcc-java
| @@ -144,6 +146,9 @@ fi
|
|
|  %changelog
| +* Thu Oct 04 2012 Pavel Raiskup <praiskup@redhat.com> - 2.4.2-8
| +- make the libtool dependant on tar (#794675)
| +
|  * Fri Sep 21 2012 Dan Horák <dan[at]danny.cz> - 2.4.2-7
|  - rebuild for gcc 4.7.2

Pavel


Note You need to log in before you can comment on or make changes to this bug.