Bug 79468 - Autorun + causes lockups with audio CDs in KDE
Autorun + causes lockups with audio CDs in KDE
Product: Red Hat Linux
Classification: Retired
Component: autorun (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-12-11 18:13 EST by Roberto Scaramuzzi
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-29 05:07:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roberto Scaramuzzi 2002-12-11 18:13:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Red Hat 8.0 uses autorun by default (through use of an Autorun item in

This created problems for me when inserting audio CDs. The autorun binary
launches an unresponsive kscd (the window appears but does not respond to clicks
or get updated when covered by another window then uncovered). In addition the
system load went over 5 . Running top showed that autorun and kjournald were the
main processes that used up CPU time (which seems to suggest this has something
to do with ext3 also). The console showed many SCSI errors and resets.

I ended up having to restart my machine with the reset button (the console had
become completely unresponsive)

The problem disappeared after I removed the Autorun item from the Autostart folder

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start a KDE session with the default Redhat 8.0 setup
2.Insert an audio CD in the CDROM drive

Actual Results:  See above

Additional info:

I'm using a new machine with a generic CD/CD-RW drive.

More hardware details available upon request.
I tried with two different auido CDs, with the same result.
Comment 1 Harald Hoyer 2003-01-09 08:33:29 EST
ouch... this is strange and the first report of this kind...
Comment 2 Harald Hoyer 2003-01-09 09:43:10 EST
hmm, workx for me.. can you run autorun with the -v option from a terminal?
$ autorun -v

Comment 3 Harald Hoyer 2003-08-05 04:32:02 EDT
ping??? more info or close the bug please
Comment 4 Harald Hoyer 2004-01-29 05:07:37 EST
closed, due to no response...

Note You need to log in before you can comment on or make changes to this bug.