Bug 795184 - omniORB-devel doesn't contain libomnisslTP4.so
Summary: omniORB-devel doesn't contain libomnisslTP4.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: omniORB
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-19 23:25 UTC by Jaromír Talíř
Modified: 2012-03-01 09:33 UTC (History)
1 user (show)

Fixed In Version: omniORB-4.1.6-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-28 10:33:27 UTC
Type: ---


Attachments (Terms of Use)

Description Jaromír Talíř 2012-02-19 23:25:55 UTC
Description of problem:

omniORB-devel package doesn't contain library libomnisslTP4.so. Version from http://omniorb.sourceforge.net/ has it. It's impossible to build omniORBpy without this library.

Version-Release number of selected component (if applicable):

omniORB-devel-4.1.6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Haïkel Guémar 2012-02-20 10:08:32 UTC
Thanks for reporting this issue. OmniORB is not built with openssl support as it is litigious (OpenSSL license is not compatible with GPLv2+), but Fedora Legal thinks it's ok under the assumption that openSSL is shipped as a "system library" under Fedora. 
I'm not 100% sure that Fedora Legal is right, but as long as they provide the legal shield, well, their problem, not mine. :]

> It's impossible to build omniORBpy without this library.

I did (it even builds in mock using current package), here's omniORBpy pending review:
https://bugzilla.redhat.com/show_bug.cgi?id=783064


Anyway, i'll file an update soon enabling openssl by default (with a rpm conditional to disable it at compile time).

Comment 2 Fedora Update System 2012-02-20 14:42:32 UTC
omniORB-4.1.6-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/omniORB-4.1.6-2.fc17

Comment 3 Fedora Update System 2012-02-20 15:25:39 UTC
omniORB-4.1.6-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/omniORB-4.1.6-2.fc16

Comment 4 Fedora Update System 2012-02-20 16:37:44 UTC
omniORB-4.1.6-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/omniORB-4.1.6-2.fc15

Comment 5 Fedora Update System 2012-02-20 17:11:26 UTC
Package omniORB-4.1.6-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing omniORB-4.1.6-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2046/omniORB-4.1.6-2.fc17
then log in and leave karma (feedback).

Comment 6 Jaromír Talíř 2012-02-21 21:45:33 UTC
Thanks. I have tested, works for me, so I added karma.

Comment 7 Fedora Update System 2012-02-28 10:33:27 UTC
omniORB-4.1.6-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-03-01 09:32:54 UTC
omniORB-4.1.6-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-03-01 09:33:26 UTC
omniORB-4.1.6-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.