Bug 795437 - remote-viewer: honor hot keys passed via controller
remote-viewer: honor hot keys passed via controller
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: 6.3
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On: 801620
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-20 09:38 EST by David Jaša
Modified: 2012-06-20 08:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-1.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-02-20 09:38:24 EST
Description of problem:
virt-viewer uses it's hardcoded hot-keys instead of ones passed via spice controller

Version-Release number of selected component (if applicable):
virt-viewer-0.5.0-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. in spice-xpi test page, set hot-keys to non-default ones (e.g. "release-cursor=shift+f5,toggle-fullscreen=shift+f6")
2. start client from the page
3.
  
Actual results:
client still uses ctrl+alt for release-cursor and F11 for to-fullscreen-only fs-toggle

Expected results:
shortcuts passed via controller are used only - ie shift-F11 is trapped by client and used for both-way fullscreen toggle, shift-F12 is trapped and used for cursor release

Additional info:
Comment 2 Marc-Andre Lureau 2012-03-01 10:55:58 EST
bug fixed in virt-viewer upstream, should be part of upcoming 0.5.2 release
Comment 14 Marian Krcmarik 2012-03-17 16:51:02 EDT
Based on comments #13 and comment #11 I am moving to ASSIGNED
Comment 16 zhe peng 2012-03-30 06:56:18 EDT
verify with:
spice-gtk-0.11-5.el6.x86_64
spice-xpi-2.7-14.el6.x86_64
spice-gtk-tools-0.11-5.el6.x86_64
spice-glib-0.11-5.el6.x86_64
spice-gtk-python-0.11-5.el6.x86_64
virt-viewer-0.5.2-3.el6.x86_64
libvirt-0.9.10-9.el6.x86_64

step same with comment 11
change Hot key to "release-cursor=shift+f5,toggle-fullscreen=shift+f6"
the guest can use shift+f5 to release-cursor and use shift+f6 to fullscreen.
verification passed.
Comment 17 Daniel Berrange 2012-04-17 07:33:39 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 19 errata-xmlrpc 2012-06-20 08:11:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.