Bug 795756 - sanlock/wdmd init scripts have bad path to restorecon
sanlock/wdmd init scripts have bad path to restorecon
Status: CLOSED DUPLICATE of bug 782600
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sanlock (Show other bugs)
6.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: David Teigland
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-21 08:18 EST by Miroslav Grepl
Modified: 2012-02-21 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 11:36:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Grepl 2012-02-21 08:18:58 EST
Description of problem:

Your init scripts contain

[ -x /usr/sbin/restorecon ] && restorecon /var/run/$prog

but restorecon is placed in /sbin


How reproducible:

$ service sanlock start
$ service wdmd start

and you get AVC msgs because /var/run/sanlock and /var/run/wdmd are mislabeled.


So you need to make this change

-[ -x /usr/sbin/restorecon ] && restorecon /var/run/$prog
+[ -x /sbin/restorecon ] && restorecon /var/run/$prog
Comment 1 David Teigland 2012-02-21 11:36:23 EST
Thanks, this will be fixed in the rebased sanlock package.

*** This bug has been marked as a duplicate of bug 782600 ***

Note You need to log in before you can comment on or make changes to this bug.