Bug 7963 - Xconfigurator fails to set keymap
Xconfigurator fails to set keymap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-23 05:26 EST by Richard Allen
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 08:09:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 1999-12-23 05:26:04 EST
After installing a RedHat 6.1 (I've only tested this on i386) the
keymap in X is incorrectly set.  During Installation I select the
is-latin1 keymap (I have to use the text mode installer because that
keymap is missing from anaconda (reported in another bug report))

After Installation the keymap in X is still the US keymap.  the problem
in /etc/X11/XF86Config is that the following two lines appear:

   XkbSymbols      "us(pc101)"
   XkbLayout       "is"

when they shoyuld be:

   XkbSymbols      "is(pc101)"
   XkbLayout       "is"

This is generating lots of questions from novice users, and this was not
a problem in Earlier releases of RedHat linux.
Comment 1 Riley H Williams 1999-12-23 15:48:59 EST
This is not limited to the is keymap, but also occurs with the uk keymap, and I
would suspect with all other non-US ones.
Comment 2 Pekka Savola 2000-01-17 04:45:59 EST
<WAKEY WAKEY - Please do something about this>

This also happens with fi-latin1 keyboards.  Therefore we can be pretty sure
non-US is the key.
Comment 3 Riley H Williams 2000-01-18 08:09:59 EST
The obvious assumption is that whilst the installation script asks what keymap
is used, and uses that internally, one of the following is true:

 1. The installation script does not install the selected setting on the
    target system.

 2. Although the installation script installs the selected setting on the
    target system, it gets overwritten with the US setting later in the
    installation.

Either way, it definately needs fixing...
Comment 4 Trond Eivind Glomsrxd 2000-07-11 14:17:32 EDT
This was fixed for Red Hat Linux 6.2 (Icelandic possibly excepted, which should
be fixed in our trees now)

Note You need to log in before you can comment on or make changes to this bug.