Bug 796620 - Not compatible with JDK7
Not compatible with JDK7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: easymock2 (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 05:44 EST by jiri vanek
Modified: 2012-03-01 20:22 EST (History)
1 user (show)

See Also:
Fixed In Version: easymock2-2.5.2-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 20:22:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git-formated patch (25.67 KB, patch)
2012-02-23 05:46 EST, jiri vanek
no flags Details | Diff

  None (edit)
Description jiri vanek 2012-02-23 05:44:41 EST
After mass rebuild for default JDK in F17 - OpenJDK7 easymock2 was not compiled due to name clash in EasyMock.java class.
Comment 1 jiri vanek 2012-02-23 05:46:17 EST
Created attachment 565256 [details]
git-formated patch

this patch is renaming affected methods. The new names are compatible with easymock3. Test file was also fixed accordingly (from easymock3) and so was spec file.
Comment 2 Fedora Update System 2012-02-23 06:34:00 EST
easymock2-2.5.2-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/easymock2-2.5.2-6.fc17
Comment 3 Fedora Update System 2012-02-23 17:30:12 EST
Package easymock2-2.5.2-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing easymock2-2.5.2-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2293/easymock2-2.5.2-6.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-01 20:22:55 EST
easymock2-2.5.2-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.