Bug 796823 - version in UI footer relies on git and wrong package
version in UI footer relies on git and wrong package
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: beta
: 1.0
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 12:58 EST by Tom McKay
Modified: 2014-11-09 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 20:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-02-23 12:58:24 EST
Description of problem:

The version displayed in the footer on a system w/o git will show as "Unknown".

SAM is also querying the wrong rpm to get the version (it is using 'katello')

See config/initializers/app_config.rb
Comment 1 Tom McKay 2012-02-23 13:03:32 EST
If the correct package is used, then the call to 'git' should be alright. The community version would fall back to this.
Comment 2 Tom McKay 2012-02-24 11:26:05 EST
RPM to check for SAM is katello-headpin
for CFSE check katello
Comment 3 Jordan OMara 2012-02-28 16:26:41 EST
committed 0b58daf5b59e8e9eaac1f302e0ea7c5cf769744c; now uses katello-headpin for headpin and katello-common for katello (katello-common & katello will always have the same version)
Comment 4 Eric Sammons 2012-03-06 13:41:49 EST
VERIFIED

Footer version now shows the version of katello-headpin-all

Note You need to log in before you can comment on or make changes to this bug.